# 데이터베이스 복원 실패

**URL:** <https://meta.discourse.org/t/failed-to-restore-db/131137>\
**Category:** Self-hosting\
**Created:** [10월 16, 2019, 6:38오전 UTC](https://meta.discourse.org/t/failed-to-restore-db/131137 "2019-10-16T06:38:28Z")\
**Posts on this page:** 1\
**Showing post:** 1

<div class="post-metadata">

**Author:** ![Rasin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rasin/32/130523_2.png) [@Rasin](https://meta.discourse.org/u/Rasin)\
**Post date:** [10월 16, 2019, 6:38오전 UTC](https://meta.discourse.org/t/failed-to-restore-db/131137/1 "2019-10-16T06:38:28Z")

</div>

새 서버에 백업을 복원하려 했더니 몇 가지 오류가 발생했습니다.

로그는 여기 있습니다: [https://paste.ubuntu.com/p/RDRbX9NRg5/](https://paste.ubuntu.com/p/RDRbX9NRg5/)

오류는 아마도 다음과 같습니다:

```plaintext
PG::UniqueViolation: ERROR: could not create unique index "unique_index_categories_on_slug"
DETAIL: Key (COALESCE(parent_category_id, '-1'::integer), slug)=(5, ) is duplicated.

```

DB 문제인 것 같았지만, 저는 DB를 수정하지 않았습니다. 그냥 백업 tar 파일을 다운로드해서 복원했을 뿐인데 잘못 복원된 것 같습니다.

도와주세요!

---

_[View the full topic](https://meta.discourse.org/t/failed-to-restore-db/131137)._
