# Failed upgrade from 3.5.0.beta8-dev to 3.6.0.beta1

**URL:** https://meta.discourse.org/t/failed-upgrade-from-3-5-0-beta8-dev-to-3-6-0-beta1/385381
**Category:** Self-hosting
**Created:** [October 12, 2025, 9:13pm UTC](https://meta.discourse.org/t/failed-upgrade-from-3-5-0-beta8-dev-to-3-6-0-beta1/385381 "2025-10-12T21:13:03Z")
**Posts on this page:** 1
**Showing post:** 1

<div class="post-metadata">

### Author: ![xyzzy](https://avatars.discourse-cdn.com/v4/letter/x/e36b37/32.png) [@xyzzy](https://meta.discourse.org/u/xyzzy)
#### Post date: [October 12, 2025, 9:13pm UTC](https://meta.discourse.org/t/failed-upgrade-from-3-5-0-beta8-dev-to-3-6-0-beta1/385381/1 "2025-10-12T21:13:03Z")

</div>

I’m self-hosted and have 3 of the plugins that were recently moved to core.

My upgrade steps:

1. Edited containers/app.yml and removed the lines for the 3 plugins (data-explorer, solved, assign)
2. cd /var/discourse
3. sudo ./launcher rebuild app

The rebuild takes the usual 5 minutes and seems to complete normally.

However, when I attempt to connect to the site, I get no response.

The last few lines in /var/discourse/shared/standalone/log/rails/production.log are:

`Booted Rails 8.0.3 application in production environment`  
`Running in ruby 3.3.8 (2025-04-09 revision b200bad6cd) [x86_64-linux]`  
`See LICENSE and the LGPL-3.0 for licensing details.`  
`Upgrade to Sidekiq Pro for more features and support: ``https://sidekiq.org`  
`Sidekiq 7.3.9 connecting to Redis with options {:size=>5, :pool_name=>“default”, :host=>“localhost”, :port=>6379, :db=>1, :url=>nil}`  
`Sidekiq 7.3.9 connecting to Redis with options {:size=>10, :pool_name=>“internal”, :host=>“localhost”, :port=>6379, :db=>1, :url=>nil}`  
`Sidekiq 7.3.9 connecting to Redis with options {:size=>10, :pool_name=>“internal”, :host=>“localhost”, :port=>6379, :db=>1, :url=>nil}`  
`Sidekiq 7.3.9 connecting to Redis with options {:size=>10, :pool_name=>“internal”, :host=>“localhost”, :port=>6379, :db=>1, :url=>nil}`  
`Sidekiq 7.3.9 connecting to Redis with options {:size=>10, :pool_name=>“internal”, :host=>“localhost”, :port=>6379, :db=>1, :url=>nil}`  
`Sidekiq 7.3.9 connecting to Redis with options {:size=>10, :pool_name=>“internal”, :host=>“localhost”, :port=>6379, :db=>1, :url=>nil}`

The last few lines in /var/discourse/shared/standalone/log/rails/unicorn.stderr.log are:

`/var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus/backends/redis.rb:291:in global_subscribe' /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus.rb:769:in global_subscribe_thread’`  
`/var/www/discourse/vendor/bundle/ruby/3.3.0/gems/message_bus-4.4.1/lib/message_bus.rb:740:in `block in new_subscriber_thread’`  
`unknown OID 23281: failed to recognize type of ‘embeddings’. It will be treated as String.`

I also tried rebuilding a 2nd time and its still not working.

Any idea what’s going on?

---

_[View the full topic](https://meta.discourse.org/t/failed-upgrade-from-3-5-0-beta8-dev-to-3-6-0-beta1/385381)._
