# Failed web upgrade

**URL:** https://meta.discourse.org/t/failed-web-upgrade/246664
**Category:** Self-hosting
**Created:** [November 24, 2022, 5:21pm UTC](https://meta.discourse.org/t/failed-web-upgrade/246664 "2022-11-24T17:21:30Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [November 24, 2022, 5:35pm UTC](https://meta.discourse.org/t/failed-web-upgrade/246664/2 "2022-11-24T17:35:00Z")

</div>

Hello and welcome @Nanovitruvius 🙂

There have been a [couple of reports of failed upgrades](https://meta.discourse.org/t/error-updating/246652/13) in the past hour or so, and a couple of fixes have now been put in place for those which seemed to have worked for most. 👍

The error `"alter schema public owner to discourse;"` in your second codeblock cropped up the other day too, and the advice was:

> [@Building bootstrap error](https://meta.discourse.org/t/building-bootstrap-error/246175/44):
>
> I’m guessing, but it seems possible that the database was uncleanly shutdown, needs to do a recover, and isn’t quite being given enough time to finish that.
> 
> In fact, see this previous thread:
> 
> > [@Discourse update doesn't wait for Postgress DB to shut down](https://meta.discourse.org/t/discourse-update-doesnt-wait-for-postgress-db-to-shut-down/212961/4):
> >
> > Whenever this happens, we usually (temporarily, as otherwise Git gets confused when updating the next time) replace the `sleep 5` with a few more seconds so that Postgres has more time to settle/recover.
> > 
> > [discourse\_docker/postgres.template.yml at 4cd6a5d96ab1efee9b6893d781c8af9d3d2f56e2 · discourse/discourse\_docker · GitHub](https://github.com/discourse/discourse_docker/blob/4cd6a5d96ab1efee9b6893d781c8af9d3d2f56e2/templates/postgres.template.yml#L207-L208)
> 
> and perhaps see also this much earlier thread:
> 
> > [@FATAL: the database system is starting up](https://meta.discourse.org/t/fatal-the-database-system-is-starting-up/52806/5):
> >
> > Try increasing the sleep in templates/postgres.template.yml locally. Is your server slow? Database too big?

---

_[View the full topic](https://meta.discourse.org/t/failed-web-upgrade/246664)._
