# Failing to connect to redis after fresh install

**URL:** https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007
**Category:** Self-hosting
**Created:** [12월 11, 2018, 2:27오후 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007 "2018-12-11T14:27:30Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![majestic](https://avatars.discourse-cdn.com/v4/letter/m/a88e4f/32.png) [@majestic](https://meta.discourse.org/u/majestic)
#### Post date: [12월 11, 2018, 2:27오후 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007/1 "2018-12-11T14:27:30Z")

</div>

Hi there.

I am creating a fresh install of Discourse on AWS EC2 with Ubuntu 16.04LTS. Unfortunately i am running into this issue:

```plaintext
`Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED) subscribe failed, reconnecting in 1 second. Call stack ["/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:344:in `rescue in establish_connection'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:328:in `establish_connection'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:99:in `block in connect'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:291:in `with_reconnect'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:98:in `connect'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:363:in `ensure_connected'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:219:in `block in process'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:304:in `logging'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:218:in `process'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis/client.rb:118:in `call'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis.rb:889:in `block in get'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis.rb:45:in `block in synchronize'", "/usr/local/lib/ruby/2.5.0/monitor.rb:226:in `mon_synchronize'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis.rb:45:in `synchronize'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/redis-4.0.1/lib/redis.rb:888:in `get'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/message_bus-2.2.0.pre.1/lib/message_bus/backends/redis.rb:360:in `process_global_backlog'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/message_bus-2.2.0.pre.1/lib/message_bus/backends/redis.rb:271:in `block in global_subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/message_bus-2.2.0.pre.1/lib/message_bus/backends/redis.rb:284:in `global_subscribe'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/message_bus-2.2.0.pre.1/lib/message_bus.rb:721:in `global_subscribe_thread'", "/var/www/discourse/vendor/bundle/ruby/2.5.0/gems/message_bus-2.2.0.pre.1/lib/message_bus.rb:669:in `block in new_subscriber_thread'"]`

```

Been searching on this topic but do not seem to see any resolution. I tired to reinstall everything but the error is persisting.

Also i have re-checked my mail settings.

---

<div class="post-metadata">

### Author: ![majestic](https://avatars.discourse-cdn.com/v4/letter/m/a88e4f/32.png) [@majestic](https://meta.discourse.org/u/majestic)
#### Post date: [12월 11, 2018, 3:46오후 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007/2 "2018-12-11T15:46:34Z")

</div>

I can verify that same problem occurs on Ubuntu 18.04 LTS

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [12월 11, 2018, 3:57오후 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007/3 "2018-12-11T15:57:19Z")

</div>

Is this a [standard install](https://meta.discourse.org/t/142537?silent=true) created with discourse-setup?

---

<div class="post-metadata">

### Author: ![majestic](https://avatars.discourse-cdn.com/v4/letter/m/a88e4f/32.png) [@majestic](https://meta.discourse.org/u/majestic)
#### Post date: [12월 11, 2018, 4:08오후 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007/4 "2018-12-11T16:08:07Z")

</div>

Yes, I followed this INSTALL guide:

[https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md](https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [12월 11, 2018, 6:01오후 UTC](https://meta.discourse.org/t/failing-to-connect-to-redis-after-fresh-install/104007/5 "2018-12-11T18:01:35Z")

</div>

I just did a clean install on 16.04.5 without any problems.

Do you have at least 1GB of ram? (Oh, I guess so, or `discourse-setup` would have complained).

Does `./discourse-doctor` provide any clues?
