# Failing update

**URL:** https://meta.discourse.org/t/failing-update/379986
**Category:** Self-hosting
**Created:** [August 23, 2025, 7:26am UTC](https://meta.discourse.org/t/failing-update/379986 "2025-08-23T07:26:23Z")
**Posts on this page:** 1
**Showing post:** 19

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [August 24, 2025, 12:15am UTC](https://meta.discourse.org/t/failing-update/379986/19 "2025-08-24T00:15:00Z")

</div>

`./launcher rebuild data` fails with

```plaintext
The source cluster was not shut down cleanly.
Failure, exiting
-------------------------------------------------------------------------------------
UPGRADE OF POSTGRES FAILED

Please visit https://meta.discourse.org/t/postgresql-15-update/349515 for support.

```

Looking at [PostgreSQL 15 update](https://meta.discourse.org/t/postgresql-15-update/349515) , I tried this:

```plaintext
root@www:/var/discourse# ./launcher stop web_only
x86_64 arch detected.
+ /usr/bin/docker stop -t 600 web_only
web_only
root@www:/var/discourse# ./launcher stop data
x86_64 arch detected.
data was not started !
./discourse-doctor may help diagnose the problem.
root@www:/var/discourse# tail -f shared/standalone/log/var-log/postgres/current
tail: cannot open 'shared/standalone/log/var-log/postgres/current' for reading: No such file or directory
tail: no files remaining
root@www:/var/discourse# 

```

---

_[View the full topic](https://meta.discourse.org/t/failing-update/379986)._
