Failure when trying to manually upgrade on CentOS 6.7


(David Compton) #1

Refer to this post

I have a similar problem with regards to update failure. I have followed the suggestions in the referenced post - updating to the latest docker version then running:

cd /var/discourse
git pull
./launcher rebuild app

When I did this it went through the process of downloading the latest image, however after about 1 minute the terminal session closed and my VPS became inaccessible. The only way I could get back into the VPS was to power it off and back on.

Now when I try to run ./launcher rebuild app again I get the following :

Error response from daemon: EOF
Your Docker installation is not working correctly

See: Docker error on Bootstrap

The referenced article does not really help. Any suggestions on how to get my discourse back up and running?


(Jeff Atwood) #2

Sounds like you maybe ran out of disk space?


(David Compton) #3

Yes I did run out of disk space, however I fixed that problem before attempting the steps outlined above. Currently I have something like 53 gb free space.


(Jeff Atwood) #4

Looks like the out of disk space corrupted some aspect of your install. I would try removing and re installing Docker to start.


(David Compton) #5

Uninstalled, reinstalled, verified that docker is running ok by running the hello-world docker container. After this the system started freezing again when trying to run the Docker hello-world container. Ran Yum Update to update all packages. Now hello-world runs OK , But I am back to exactly the same result when I come back to try to rebuild the app. I’m running Docker v1.7.1 on CentOS 6.7.

Here is the full result of trying to rebuild the app:

[root@vps discourse]# sudo ./launcher rebuild app
which: no docker.io in (/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin)

WARNING: We are about to start downloading the Discourse base image
This process may take anywhere between a few minutes to an hour, depending on your network speed

Please be patient

Error response from daemon: EOF
Your Docker installation is not working correctly

See: Docker error on Bootstrap

I read that there seems to be a lot of problems with Docker running on CentOS. What are my options here… ? Is there a way to retrieve my discourse data and move onto a different server?

In case it helps here are a list of installed Docker containers:

[root@vps discourse]# docker ps -a
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
cb1d4d637913 hello-world “/hello” 31 seconds ago Exited (0) 31 seconds ago jolly_galileo
0d5fd106902b hello-world “/hello” 10 minutes ago Exited (0) 10 minutes ago kickass_jang
70c8c8d50ccf hello-world “/hello” 10 minutes ago Exited (0) 10 minutes ago silly_jang
8c709ec185b6 hello-world “/hello” 21 minutes ago Exited (0) 21 minutes ago grave_cori
80f12c4eec6f hello-world “/hello” 21 minutes ago Exited (0) 21 minutes ago silly_torvalds
0fa36c1ac287 hello-world “/hello” 22 minutes ago Exited (0) 22 minutes ago evil_payne
37c7dc357199 hello-world “/hello” 38 minutes ago hopeful_fermat
450cd3333b2a hello-world “/hello” 43 minutes ago Exited (0) 43 minutes ago mad_kirch
a3c4a430b6a3 samsaffron/discourse:1.0.7 “echo working” 15 hours ago gloomy_lovelace
6b68a7b02607 samsaffron/discourse:1.0.7 “echo working” 16 hours ago cranky_mclean
7040325fd007 local_discourse/app “/sbin/boot” 14 months ago Up 22 minutes 0.0.0.0:2222->22/tcp, 0.0.0.0:85->80/tcp app


(Dean Peterson) #6

Just a guess but Docker 1.7.1 is quite old. That is the latest version available to you? If possible upgrade Docker to at least >= 1.8


(David Compton) #7

Unfortunately from what I can ascertain Docker 1.7.1 is the latest version available for Centos 6.x. I’ve investigated upgrading from Centos 6.7 to 7.x - but this is unsupported and apparently just going to end in tears according to the official CentOS docs.

So it looks like my only chance to retrieve my data is to move to a new server. I see the process as being something like the following:

  1. Setup a new Linux server
  2. Install the latest version of docker
  3. Move the entire contents of my /var/discourse directory to the new server
  4. Run the manual upgrade on the new server

Does this sound like the correct process - in particular step 3?


(David Compton) #8

I managed to salvage my Discourse installation by doing the following:

  1. Setup a new Ubuntu 14:04 server
  2. Install Discourse on new server as per normal process
  3. Restore Discourse backup from my old installation to my new installation

I was worried that this would not work as the old installation had not been upgraded to the latest version, and so was on a different version to the new installation. However all seems to be running OK.

Q: Does this mean that my database may not match the version latest version, even though everything appears to be running OK? If so what can I/should I do about it?

Thanks,

David


(Kane York) #9

You’re fine, restores from older -> newer were always meant to work and always have worked.