Favicon Fails to Appear After Domain Change


(Jonathan Rogers) #1

This is a very minor issue. After a successful install, forum members wanted a domain change. After the rebuild, the favicon hasn’t being displaying (even cleared browser cache etc). The path: “/images/favicon.ico” and image were never altered so there shouldn’t be a problem. Any ideas?


(Kane York) #2

What happens if you convert the favicon to a png and put it in both favicon url and apple touch icon url ?


(Jonathan Rogers) #3

Tried your idea.No effect. I am curious, why did you suggest changing the apple touch icon? Are these two connected in some way?


(Kane York) #4

Where’s your forum so I can take a look at what it’s showing?


(Wes Osborn) #5

Browsers are pretty aggressive about caching favicons, have you tried this yet? How do I force a favicon refresh - Stack Overflow


(Jonathan Rogers) #6

The forum in question: http://honestcleaner.com/


(Jonathan Rogers) #7

Tried that but there may be a problem with the path since it is 404.
http://honestcleaner.com/image/favicon.ico


(Kane York) #8

Here’s what’s in the <head>:

<link rel="icon" type="image/png" href="/images/favicon.png">
<link rel="apple-touch-icon" type="image/png" href="/images/apple-touch-HC-icon.png">
<link rel="icon" sizes="144x144" href="/images/apple-touch-HC-icon.png">

Where are your favicon images supposed to be?


(Jonathan Rogers) #9

I see one problem /image/ vs /images/. But that is me making a grammatical mistake after the issue.