Finalizing configuration: logged in with the developer email, not made admin

(Marco) #1


I have installed Discourse on DigitalOcean with no problems so far. Then I need to finalize the configuration as suggested.

When I go to my homepage a message says:

Congratulations, you installed Discourse! Register a new admin account with to finalize configuration.

I have then registered a new account with that email address and I have received the confirmation email, so the email sending works.

The problem is that I continue to see the above message and my newly created user (called Admin) is not an administrator. I don’t see a gear or wrench icon or something like that to configure my forum.

This is the top-right corner of my Admin account:

The DNS has not propagated yet, so I am accessing the home page using my server’s IP address provided by DigitalOcean.

What should I do?

(Michael Downey) #2

Just to confirm, do you not see the “Admin” link in the menu? Can you access directly?

(Marco) #3

I don’t, please see the attached image:

And I can’t access /admin:

The page you requested doesn’t exist or is private.

(Ben T) #4

Are there any extra spaces in your app.yml file near DISCOURSE_DEVELOPER_EMAILS? You can also follow the steps outlined here. I believe you will want to use ./launcher enter app though.

(Marco) #5

It is like this (with a different email of course):


edit: that is, I just changed the default email between the ’ '.

(Ben T) #6

If you make any changes to app.yml you have to rebuild the container (./launcher rebuild app) . You can also try the “hard way” I linked above if there are still issues.

(Marco) #7

I didn’t know this, it should be in the Beginner’s Guide. I had issued a stop and start. Rebuilding now…

(Marco) #8

The space after the colon is needed.
I did the hard way and it works, but I think the issue should be fixed anyhow.
Thank you all.

(Jeff Atwood) #9

So you are saying you had it like


and it did not work, but changing it to


(notice the space)


(Jens Maier) #10

YAML syntax requires all tokens to be separated by whitespace. The colon marks the key as a map key, but it does not separate it from the value.

(Zane Beckman) #11

@sam, is this possibly related to the fix you pushed for the issue described here?

(Marco) #14

To correctly answer you, we have to define “it worked”.

Yes, without the space the rebuild failed and with the space the rebuilt went ok. Even so, when I created the first member using the developer email address, the member has been created without administration abilities. I had to do it “the hard way”, and finally it worked.

Also the command to issue is not:

./launcher ssh my_app


./launcher ssh app

(Jeff Atwood) #15

Actually it turns out you are right @fysics – sam’s fix did break stuff.

I’ll let him answer.

(Sam Saffron) #16

Yes strip! was not behaving the way I expected it to.

Should be fixed with:


(Jeff Atwood) #17