[Fixed] WordPress Plugin: Posts incorrectly always publish to discourse


(Anthony Giovannetti) #1

EDIT: This bug is still not fixed.

This bug has been bothering me for a while and I am curious what is up.

Whenever I make a new post on my Wordpress site it will publish to Discourse regardless of whether I want it to or not.

For example, I just recently made a new post and the “Publish to Discourse” checkbox is unchecked.

Yet regardless of this the post is still posted to Discourse.

Making it so that I have to go in and delete the Discourse thread every time this happens. If this an error on our end or a bug in the wordpress discourse plugin?


Every time I attach media in WordPress, a separate topic is created
Emojis Not Displaying / Old Avatar Styles
Wordpress pages are offered to be sent to discourse
(David Betts) #2

@SneakySly What version of WordPress are you running? I’m getting the same issue on 3.8.3. I believe it is associated with this bug: Use parse_args to ensure default options are set by wdbetts · Pull Request #61 · discourse/wp-discourse · GitHub


(Anthony Giovannetti) #3

I keep updating to the latest.

Currently on version 3.9 and still experiencing the bug.


(Sam Saffron) #4

Can you try latest, I merged that PR


(Allen - Watchman Monitoring) #6

Updating it depeneds on how you installed it… if you navigated to the wp-content/plugins folder, then used git clone then you’d simple go back in and git pull.

In my case I was already up to date:

$ cd wp-content/plugins/wp-discourse/
wp-content/plugins/wp-discourse$ git pull
Already up-to-date.

If in doubt, simply remove the wp-discourse folder from wp-plugins and upload the latest version by downloading the .zip from the repo’s main page:

Then upload the .zip into your plugins folder, and decompress it.

For our setup, I haven’t had the same issue - I was able to post a blog entry with the checkbox de-selected, and it didn’t go to Discourse.


(Anthony Giovannetti) #7

Thanks for the confirmation @watchmanmonitor.

Indeed we are doing exactly that and still the publish to discourse checkbox might as well not exist. Just checked yet again moments ago after getting a fresh version of the plugin. :frowning:

Edit: To clarify, we did: [quote=“watchmanmonitor, post:6, topic:14247”]
simply remove the wp-discourse folder from wp-plugins and upload the latest version by downloading the .zip from the repo’s main page:
[/quote]

And the bug is still very much not fixed.

EDIT: I think this plugin is easily the worst part of Discourse currently. The amount of extra work this error generates for me is getting increasingly insane. Having basic functionality still not work is simply bizarre.


(Anthony Giovannetti) #8

It looks like there is another PR that claims to fix this problem:

https://github.com/discourse/wp-discourse/pull/65

EDIT: Thanks for merging the PR! The issue is totally fixed now and working great. :smile: Made my day.