# Fixing discourse after disk full

**URL:** https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426
**Category:** Self-hosting
**Tags:** server-resources
**Created:** [September 25, 2020, 10:35pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426 "2020-09-25T22:35:28Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![dhoop](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/dhoop/32/195293_2.png) [@dhoop](https://meta.discourse.org/u/dhoop)
#### Post date: [September 25, 2020, 10:35pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/1 "2020-09-25T22:35:28Z")

</div>

My AWS ec2 instance ran out of disk space (it has 16GB). I ran `rm -rf /var/lib/docker/overlay2` and `journalctl --vacuum-time=10d` to free up space, and now `df` says I have 7GB of free space. after rebooting the instance I get `Connection refused` when trying to connect to the page.

I tried `sudo ./launcher rebuild app` but it fails saying there less than 5GB of disk space.

Any suggestions?

---

<div class="post-metadata">

### Author: ![IAmGav](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/iamgav/32/235598_2.png) [@IAmGav](https://meta.discourse.org/u/IAmGav)
#### Post date: [September 25, 2020, 10:47pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/2 "2020-09-25T22:47:48Z")

</div>

try

`./launcher cleanup `

---

<div class="post-metadata">

### Author: ![Stephen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/stephen/32/95011_2.png) [@Stephen](https://meta.discourse.org/u/Stephen)
#### Post date: [September 26, 2020, 12:25am UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/3 "2020-09-26T00:25:53Z")

</div>

25GB is usually the recommended minimum. Even if you can get it back up running with your current allocation this is going to happen again with such a small volume.

---

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [September 26, 2020, 12:06pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/4 "2020-09-26T12:06:27Z")

</div>

Just to note, Hetzner’s lowest tier offers only 20GB, but that’s been working for me. It can be worth tidying up the backups directory before trying an upgrade: having, of course, taken a new backup and copied it elsewhere for safety. (It’s a small forum: a backup is 120MB.)

In another case, I use Digital Ocean’s lowest tier, offering 25G, and in that case the forum’s backup comes in at 640MB.)

The one time I had trouble, it was the journal thing, but I cut that right down:

```
# journalctl --disk-usage
Archived and active journals take up 104.0M in the file system.

```

---

<div class="post-metadata">

### Author: ![dhoop](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/dhoop/32/195293_2.png) [@dhoop](https://meta.discourse.org/u/dhoop)
#### Post date: [September 26, 2020, 2:41pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/5 "2020-09-26T14:41:39Z")

</div>

Ok, I have increased the size of the disk so discourse-doctor sees 40G (29% used) so space is no longer the issue. I need help getting discourse up and running.

`sudo ./launcher start app` fails with  
`Unable to find image 'local_discourse/app:latest' locally`

The failing output of `sudo launcher rebuild app` is [here](https://pastebin.com/KkkUkK06)

How do I fix this?

---

<div class="post-metadata">

### Author: ![dhoop](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/dhoop/32/195293_2.png) [@dhoop](https://meta.discourse.org/u/dhoop)
#### Post date: [September 26, 2020, 3:17pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/6 "2020-09-26T15:17:27Z")

</div>

ok I got `sudo launcher rebuild app` to work by changing “templates/postgres.template.yml” to “templates/postgres.10.template.yml” in app.yml

Should I leave that change, or change it back and try rebuilding?

---

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [September 26, 2020, 3:27pm UTC](https://meta.discourse.org/t/fixing-discourse-after-disk-full/165426/7 "2020-09-26T15:27:04Z")

</div>

I think you need to visit the [postgres update thread](https://meta.discourse.org/t/postgresql-12-update/151236) and ask for help…

```
1. UPGRADE OF POSTGRES FAILED

 * Please visit https://meta.discourse.org/t/postgresql-12-update/151236 for support

```
