Flag icon but no flags?


(omfg) #1

This is on v1.5.0.beta4 +8. I have the flag icon, but there’s nothing in the queue. I tried to refresh and restart the browser, although I didn’t expect that would change anything (and it didn’t).


(Régis Hanol) #2

Are you sure it’s a flag and not something for a plugin?


(omfg) #3

Well, clicking on the red icon took me to Flags.

Incidentally, I tried a different browser (I could have tried Incognito/Private window too) and I clicked on the same icon, but this time that action took me to “Needs Approval” where I found a spam message which I rejected.

I don’t know if this behavior may have been impacted by other user’s behavior before and later (when I used a different browser), but this can be considered “Solved”, although I don’t quite understand why/how.

Btw, I have docker_manager, lazyYT and poll, just these 3.


(Jeff Atwood) #4

Is it from Akismet? We had a customer get confused by that recently.


(omfg) #5

I think not (I am not aware of Akismet setup, I just have those 3 plugins that I mentioned above).

I just checked my settings, filtered by overridden only and there’s nothing non-default in the Spam section.

Flags > Old is completely empty, and so is Log > Staff Actions for yesterday (there are older entries in here), so I can’t see the details of my action yesterday.


(David Maxwell) #6

Are you logged in as an administrator? If not, it could be a flagged PM. They still show the flag icon but no flags will be shown.


(omfg) #7

Yes, in admin/users/list/staff I got a badge that says “Discourse Admin”.

Edit 1: I ran into this again. I don’t know what else to do so I just popped the JavaScript debugger to check whether this may be a flagged PM or plugin-related issue: it says it’s a flagged post notification.
I don’t know if any other mod may do something on their side and remove this condition, but while it’s there if anyone has any suggestion I can make additional checks from the browser (I don’t have access to the CLI/Docker).

Edit 2: Ugh, problem solved (screenshot below).
So it could be what Jeff suggested - Akismet (or some other, built-in anti-spam mechanism) - but perhaps UI could be improved so that the link doesn’t take people to a wrong place (Flags > Active)?
In case it’s not clear from the screenshot below, the reason for the flag was a (spammy) post which could be found by clicking on the other red circle next to Needs Approval, but to see that user would have to click the hamburger menu and then Needs Approval rather than the upper red circle.