Flickr profile URLs incorrectly onebox


(Steevithak) #1

My hackerspace recently installed a Discourse forum and while it’s not too bad overall, it has one super-annoying bug which I’d love to see fixed. In most posts I make, I seem to be able to include a URL, for example, here’s the URL of Google:

Works fine. However, I’m a flickr user and frequently need to give people a link to my flickr account. This seems to be impossible within Discourse. When I add my flickr URL, Discourse eats it, erases it, and replaces it with an arbitrary photo that it has pulled out of my flickr photostream (and the photo doesn’t seem to be a link to either the original flickr URL or to the photo itself, which is license violation for CC-licensed photos but that’s another issue). I’d provide a demonstration here but this forum apparently doesn’t allow photos posted and Discourse thinks all Flickr URLs are photos.

But I think I can squeeze the URL in with backticks to at least give you the ability to try it out in a post yourself - as you can see, this is just a URL, not unlike the google URL, so it seems like I should be able to insert it into a post in a form that would be active (hot, linkable, clickable, whatever you want to call it). But this isn’t possible.

This behavior is broken, non-useful, incorrect, etc. I could certainly understand providing a way to insert or embed a particular Flickr photo within a post but that’s not what’s going on here. That’s NOT the URL of a photo but the URL of my Flickr photostream. This bug prevents me from providing my flickr URL within posts. Instead, I usually have to resort to email or a text to send my Flickr info.

Hopefully that makes sense. Happy to answer questions if it’s not clear.


(Régis Hanol) #2

What about that link?

(Steevithak) #3

Interesting. Can you describe how you did that? I’m not able to. If I paste the URL into this reply, for example, the preview replaces it with a random pic from my photostream and posting is then disallowed because of the “no photos” policy. It looks like you swapped it from https:// to http:// but I tried that too and it still triggers the bug that replaces the URL with an image.

(Khoa Nguyen) #4

Ah. It a Discourse feature called Onebox. But sometimes, it doesn’t help much. Try to remove the protocol or wrap the link in markdown syntax

(Kane York) #5

turns into

(Steevithak) #6

Tried markdown but it still triggers the bug. Leaving the protocol off does allow me to get the link in but not correctly (it uses http instead of https when rendering the link). Still this is a tolerable work-around until the bug can be fixed, thanks!

(Steevithak) #7

Interesting, it allowed you to post with the substituted the image. When I tried that, it complained that image posting wasn’t allowed and I was unable to post at all. Some kind of user-level thing specific to this forum maybe?

(Kane York) #8

(Steevithak) #9

So I can’t post an image unless I spend a lot of time reading posts unrelated to the bug I’m trying to file? Wow, seems like a weird policy for a bug reporting forum. Is that to generate more page views for ad revenue or something? Whatever, it looks like someone else has high enough privs to post images, so hopefully that makes the bug clear enough for the devs to see and understand. And I’ve got a work around for the bug, so I’m happy. :slight_smile:

(Jens Maier) #11

A lot of time? TL1 requires:

  • entering 5 topics,
  • reading 30 posts,
  • waiting 10 minutes.

Just figuring out how to report a bug and if it’s a known bug should fulfill all of these… :sweat_smile:

(Kane York) #12

I’d like to note that you’ve already met the requirements, as your name isn’t grey anymore. It hasn’t been light gray for a while now. At a minimum, by the time you replied to me.

(Jeff Atwood) #13

@techapj can you take a peek at this? Also the recent onebox issue with short google maps URLs in a related topic here.

(Arpit Jalan) #14

Fixed via

(Régis Hanol) #15