Force https for login URL


#1

I am testing out embedded comments in a grav blog (see Embedding Discourse Comments via Javascript).
However, I am having a problem with the embed URL redirecting to the discourse login url over http instead of https.

I am running the latest discourse (docker install) on port 20090 and reverse proxying with apache2 to get the site as https.
This works well but discourse is serving internal links that map to http instead of https.
This causes a problem with embedding in an https page because browsers recognise it as insecure content.

Is there a way to force all discourse URLs to be https? I have seen the use_https setting but I’m not sure where I would put this in the config.

Also, is it possible to turn a private forum (configured in the setup) back into a public forum that doesn’t require login to see forums?


(Felix Freiberger) #2

Click the hamburger button in the top-right corner, click “:gear: settings”, search for “use https”, check that and click “:white_check_mark::slight_smile:


#3

Thank you, that was simpler than I expected!


(Mindaugas Bartusevičius) #4

Not working plz help!