Force_https link in admin warning does not reset the "show overriden only" checkbox


(Anton) #1

image

This is a fairly minor issue, but you may still want to fix it.

Steps to reproduce:

  1. Go to “settings” and check the “show overriden settings only” checkbox.
  2. Enable https.
  3. Wait for the warning to appear in admin panel (see image above)
  4. Click on the force_https link
  5. A settings page is opened, but force_https setting is not found – because the “overriden only” checkbox is still ON.

Basically, the link should set the checkbox off, e.g. via a URL parameter.