# Fresh install discourse 3.4.7 fail : Failed to create 'badge\_posts' view

**URL:** https://meta.discourse.org/t/fresh-install-discourse-3-4-7-fail-failed-to-create-badge-posts-view/378853
**Category:** Self-hosting
**Tags:** badges, unsupported-install, install, postgres
**Created:** [August 16, 2025, 8:50am UTC](https://meta.discourse.org/t/fresh-install-discourse-3-4-7-fail-failed-to-create-badge-posts-view/378853 "2025-08-16T08:50:43Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![janfy](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/janfy/32/517791_2.png) [@janfy](https://meta.discourse.org/u/janfy)
#### Post date: [August 16, 2025, 8:50am UTC](https://meta.discourse.org/t/fresh-install-discourse-3-4-7-fail-failed-to-create-badge-posts-view/378853/1 "2025-08-16T08:50:43Z")

</div>

Hi,

Discourse v3.4.7 install from scratch failed with the following error :

```plaintext

08:18:53.15 INFO ==> Populating database
rake aborted!
StandardError: An error has occurred, this and all later migrations canceled: (StandardError)
Failed to create 'badge_posts' view
/opt/bitnami/discourse/lib/badge_posts_view_manager.rb:22:in `create!'
/opt/bitnami/discourse/db/migrate/20180917024729_remove_superfluous_columns.rb:64:in `up'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:997:in `public_send'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:997:in `exec_migration'
/opt/bitnami/discourse/lib/freedom_patches/schema_migration_details.rb:8:in `block in exec_migration'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/benchmark-0.4.0/lib/benchmark.rb:304:in `measure'
/opt/bitnami/discourse/lib/freedom_patches/schema_migration_details.rb:8:in `exec_migration'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:978:in `block (2 levels) in migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/benchmark-0.4.0/lib/benchmark.rb:304:in `measure'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:977:in `block in migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:415:in `with_connection'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:976:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1190:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1538:in `block in execute_migration_in_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/transaction.rb:616:in `block in within_new_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activesupport-7.2.2.1/lib/active_support/concurrency/null_lock.rb:9:in `synchronize'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/transaction.rb:613:in `within_new_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/database_statements.rb:361:in `transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1589:in `ddl_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1537:in `execute_migration_in_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1512:in `each'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1512:in `migrate_without_lock'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1457:in `block in migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1609:in `with_advisory_lock'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1457:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1264:in `up'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1239:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/tasks/database_tasks.rb:262:in `migrate'
/opt/bitnami/discourse/lib/tasks/db.rake:267:in `block (2 levels) in <main>'
/opt/bitnami/discourse/lib/distributed_mutex.rb:53:in `block in synchronize'
/opt/bitnami/discourse/lib/distributed_mutex.rb:49:in `synchronize'
/opt/bitnami/discourse/lib/distributed_mutex.rb:49:in `synchronize'
/opt/bitnami/discourse/lib/distributed_mutex.rb:34:in `synchronize'
/opt/bitnami/discourse/lib/tasks/db.rake:242:in `block in <main>'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/rake-13.2.1/exe/rake:27:in `<top (required)>'
/opt/bitnami/ruby/bin/bundle:25:in `<main>'
Caused by:
Failed to create 'badge_posts' view
/opt/bitnami/discourse/lib/badge_posts_view_manager.rb:22:in `create!' 
/opt/bitnami/discourse/db/migrate/20180917024729_remove_superfluous_columns.rb:64:in `up'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:997:in `public_send'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:997:in `exec_migration'
/opt/bitnami/discourse/lib/freedom_patches/schema_migration_details.rb:8:in `block in exec_migration'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/benchmark-0.4.0/lib/benchmark.rb:304:in `measure'
/opt/bitnami/discourse/lib/freedom_patches/schema_migration_details.rb:8:in `exec_migration'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:978:in `block (2 levels) in migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/benchmark-0.4.0/lib/benchmark.rb:304:in `measure'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:977:in `block in migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:415:in `with_connection'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:976:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1190:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1538:in `block in execute_migration_in_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/transaction.rb:616:in `block in within_new_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activesupport-7.2.2.1/lib/active_support/concurrency/null_lock.rb:9:in `synchronize'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/transaction.rb:613:in `within_new_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/connection_adapters/abstract/database_statements.rb:361:in `transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1589:in `ddl_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1537:in `execute_migration_in_transaction'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1512:in `each'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1512:in `migrate_without_lock'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1457:in `block in migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1609:in `with_advisory_lock'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1457:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1264:in `up'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/migration.rb:1239:in `migrate'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/activerecord-7.2.2.1/lib/active_record/tasks/database_tasks.rb:262:in `migrate'
/opt/bitnami/discourse/lib/tasks/db.rake:267:in `block (2 levels) in <main>'
/opt/bitnami/discourse/lib/distributed_mutex.rb:53:in `block in synchronize'
/opt/bitnami/discourse/lib/distributed_mutex.rb:49:in `synchronize'
/opt/bitnami/discourse/lib/distributed_mutex.rb:49:in `synchronize'
/opt/bitnami/discourse/lib/distributed_mutex.rb:34:in `synchronize'
/opt/bitnami/discourse/lib/tasks/db.rake:242:in `block in <main>'
/opt/bitnami/discourse/vendor/bundle/ruby/3.2.0/gems/rake-13.2.1/exe/rake:27:in `<top (required)>'
/opt/bitnami/ruby/bin/bundle:25:in `<main>'
Tasks: TOP => db:migrate
(See full trace by running task with --trace)
== 20180917024729 RemoveSuperfluousColumns: migrating =========================

```

Discourse version : **3.4.7** – commit d2137efca79b8d2015d202a8a550e62ee30c6c06 (grafted, HEAD, tag: v3.4.7)

Docker image : **bitnami/discourse:3.4.7-debian-12-r18**

Helm Chart : **bitnami/discourse**

Helm Chart version : **17.0.0**

External postgresql version : **15.10.0 (Debian 15.10-0+deb12u1)**

Database and user are created by our dba, and the database was empty.

Can you help me ?

Best regards.

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [August 16, 2025, 9:32am UTC](https://meta.discourse.org/t/fresh-install-discourse-3-4-7-fail-failed-to-create-badge-posts-view/378853/2 "2025-08-16T09:32:49Z")

</div>

Hi there, the Bitnami install is deprecated and no longer supported. You’d want to do a [standard install](https://meta.discourse.org/t/142537?silent=true) instead, as that is the official and supported method.

See also:

> [@Bitnami Discourse container image is deprecated](https://meta.discourse.org/t/bitnami-discourse-container-image-is-deprecated/374875/1):
>
> Looks like that after Bitnami was aquired by Broadcom, images such as Discourse Bitnami won’t be updated anymore. See [Upcoming changes to the Bitnami catalog (effective August 28th, 2025) · Issue #35164 · bitnami/charts · GitHub](https://github.com/bitnami/charts/issues/35164) for more information.
