# Fresh install failing - gnutls\_handshake() failed: Error in the pull function

**URL:** https://meta.discourse.org/t/fresh-install-failing-gnutls-handshake-failed-error-in-the-pull-function/49867
**Category:** Self-hosting
**Created:** [September 8, 2016, 1:44am UTC](https://meta.discourse.org/t/fresh-install-failing-gnutls-handshake-failed-error-in-the-pull-function/49867 "2016-09-08T01:44:13Z")
**Posts on this page:** 1
**Showing post:** 12

<div class="post-metadata">

### Author: ![Sisko](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sisko/32/60684_2.png) [@Sisko](https://meta.discourse.org/u/Sisko)
#### Post date: [September 8, 2016, 7:34am UTC](https://meta.discourse.org/t/fresh-install-failing-gnutls-handshake-failed-error-in-the-pull-function/49867/12 "2016-09-08T07:34:19Z")

</div>

Well it turns out the issue was in fact the MTU of the docker0 network adapter.

I resolved the issue by changing the following line:

```
ExecStart=/usr/bin/dockerd -H fd://

```

to

```
ExecStart=/usr/bin/dockerd --mtu=1400 -H fd://

```

in my `/lib/systemd/system/docker.service`

Thanks for trying to assist.

---

_[View the full topic](https://meta.discourse.org/t/fresh-install-failing-gnutls-handshake-failed-error-in-the-pull-function/49867)._
