# Generic error when existing user tries to sign in

**URL:** https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223
**Category:** SSO
**Created:** [February 10, 2017, 8:01pm UTC](https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223 "2017-02-10T20:01:09Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![zhanes](https://avatars.discourse-cdn.com/v4/letter/z/3da27b/32.png) [@zhanes](https://meta.discourse.org/u/zhanes)
#### Post date: [February 10, 2017, 8:01pm UTC](https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223/1 "2017-02-10T20:01:09Z")

</div>

I’ve got a report from a specific user that when they try logging into our forum they get the error “There is a problem with your account. Please contact the site’s administrator.”

We use SSO. I haven’t heard of this from any other users, and we’ve got a lot of them. I don’t know really anything else about the technical side of our installation – one of our developers just told me that it’s an issue on the Discourse side of things. What should I do?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 10, 2017, 9:35pm UTC](https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223/2 "2017-02-10T21:35:28Z")

</div>

Have the developer post here why he thinks it’s on the Discourse site of things

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [February 11, 2017, 2:40am UTC](https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223/3 "2017-02-11T02:40:40Z")

</div>

Check the /logs on your site when logged in as an Admin account in Discourse. You can also turn verbose SSO logging on it Site Settings.

---

<div class="post-metadata">

### Author: ![Judith](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/judith/32/289903_2.png) [@Judith](https://meta.discourse.org/u/Judith)
#### Post date: [June 10, 2018, 8:11am UTC](https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223/5 "2018-06-10T08:11:33Z")

</div>

I had the same error, with several of our users. Turns out that these users had not used the forum before, only our main site, so SSO was registering them as new as they logging in, and their IP range already had several registered users (possibly because of signing in from a university, or because we’re using Cloudflare which tends to mess up incoming IP addresses). So the Discourse “max new accounts per registration ip” setting caught them, yielding this error message. I enabled verbose SSO logging in order to understand what was going on and then increased the value there in order to fix the issue.

---

<div class="post-metadata">

### Author: ![riking](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/riking/32/170938_2.png) [@riking](https://meta.discourse.org/u/riking)
#### Post date: [June 10, 2018, 9:11pm UTC](https://meta.discourse.org/t/generic-error-when-existing-user-tries-to-sign-in/57223/6 "2018-06-10T21:11:10Z")

</div>

> [@Judith](#):
>
> because we’re using Cloudflare which tends to mess up incoming IP addresses

Fix the IP problem by including `templates/cloudflare.template.yml` in your container config.
