Get bitnami discourse working in subdirectory

unsupported-install

(Varun) #1

So here’s the situation - I’m trying to install discourse on my university’s server using the bitnami stack installer. However there is already another apache server running on port 80. Thus I used port 8082 for binding the bundled bitnami apache server. However, port 8082 isn’t open on the machine so my sysadmin setup an apache virtualhost to proxy requests internally to that port.

The normal website (the one running on port 80) is accessible through http://www.animesoc.co.uk while port 8082 is accessible through http://www.animesoc.co.uk/forums. The proxy itself works fine (I can access any text files that I make in discourse’s htdocs/public directory) but when I just try accessing /forums I simply get a blank page.

I assume this is happening because I have to change the application URL path from / to /forums to get the internal links working, but I’m not sure how to go about this. Any help would be greatly appreciated.


(Jeff Atwood) #2

Unfortunately, subfolder installs are not supported at this time.


(Varun) #3

Ah, that’s unfortunate. In that case would it possibly work if I set up a subdomain that forwards to the /forums subfolder (which I assume will further proxy the request internally)? And while specifying the hostname during the discourse installation I can enter the subdomain.

EDIT - nevermind, that doesn’t seem like it’ll work. Thanks for the clarification nonetheless.


(Jeff Atwood) #4

Subfolder installs work as of 1.3 but we only support the Docker based install.