# Getting 500 Internal Server Error in AvatarLookup after Upgrade from 2.4.2 to 2.7.7

**URL:** <https://meta.discourse.org/t/getting-500-internal-server-error-in-avatarlookup-after-upgrade-from-2-4-2-to-2-7-7/202085>\
**Category:** Bug\
**Created:** [August 30, 2021, 8:41am UTC](https://meta.discourse.org/t/getting-500-internal-server-error-in-avatarlookup-after-upgrade-from-2-4-2-to-2-7-7/202085 "2021-08-30T08:41:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dmorlock](https://avatars.discourse-cdn.com/v4/letter/d/7993a0/32.png) [@dmorlock](https://meta.discourse.org/u/dmorlock)\
**Post date:** [August 30, 2021, 8:41am UTC](https://meta.discourse.org/t/getting-500-internal-server-error-in-avatarlookup-after-upgrade-from-2-4-2-to-2-7-7/202085/1 "2021-08-30T08:41:49Z")

</div>

We are getting a HTTP 500 error for the first requests on a fresh 2.7.7 installation and recovery with data from 2.4:

```plaintext
Completed 500 Internal Server Error in 179ms (ActiveRecord: 0.0ms | Allocations: 27504)
NameError (uninitialized constant #<Class:#<Plugin::Instance:0x00007fe15d1f0e00>>::AvatarLookup)
app/models/topic_list.rb:24:in `block in preload'
app/models/topic_list.rb:24:in `preload'
app/models/topic_list.rb:148:in `load_topics'
app/models/topic_list.rb:81:in `topics'
app/serializers/suggested_topics_mixin.rb:16:in `include_suggested_topics?'
(eval):6:in `_fast_attributes'
app/controllers/application_controller.rb:519:in `render_json_dump'
app/controllers/topics_controller.rb:1147:in `block (2 levels) in perform_show_response'
app/controllers/topics_controller.rb:1137:in `perform_show_response'
app/controllers/topics_controller.rb:162:in `show'
app/controllers/application_controller.rb:395:in `block in with_resolved_locale'
app/controllers/application_controller.rb:395:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:71:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:355:in `call'
config/initializers/100-quiet_logger.rb:23:in `call'
config/initializers/100-silence_logger.rb:31:in `call'
lib/middleware/enforce_hostname.rb:23:in `call'
lib/middleware/request_tracker.rb:177:in `call'

```

After some retries, the errors seem to disappear. The error can be reproduced by restarting the discourse instance. We are using the docker based Discourse installation.

Please let me know if you need further infos or let me know how I can further investigate this issue.

Thanks,  
Daniel.

---

<div class="post-metadata">

**Author:** ![RGJ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rgj/32/523185_2.png) [@RGJ](https://meta.discourse.org/u/RGJ)\
**Post date:** [August 30, 2021, 10:33am UTC](https://meta.discourse.org/t/getting-500-internal-server-error-in-avatarlookup-after-upgrade-from-2-4-2-to-2-7-7/202085/2 "2021-08-30T10:33:23Z")

</div>

> [@dmorlock](#):
>
> `AvatarLookup`

It looks like you’re running an old version of the Discourse Assign plugin.

---

<div class="post-metadata">

**Author:** ![dmorlock](https://avatars.discourse-cdn.com/v4/letter/d/7993a0/32.png) [@dmorlock](https://meta.discourse.org/u/dmorlock)\
**Post date:** [August 30, 2021, 11:11am UTC](https://meta.discourse.org/t/getting-500-internal-server-error-in-avatarlookup-after-upgrade-from-2-4-2-to-2-7-7/202085/3 "2021-08-30T11:11:38Z")

</div>

Indeed, the “stable”-Branch was falsely used (which is stale). Switching to master solved the problem, thanks!

---

<div class="post-metadata">

**Author:** ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)\
**Post date:** [August 31, 2021, 5:39am UTC](https://meta.discourse.org/t/getting-500-internal-server-error-in-avatarlookup-after-upgrade-from-2-4-2-to-2-7-7/202085/4 "2021-08-31T05:39:22Z")

</div>


