# Получение 502 Bad Gateway после попытки обновления

**URL:** https://meta.discourse.org/t/getting-502-bad-gateway-after-attempting-upgrade/344923
**Category:** Self-hosting
**Created:** [30.Декабрь.2024 18:06:30 UTC](https://meta.discourse.org/t/getting-502-bad-gateway-after-attempting-upgrade/344923 "2024-12-30T18:06:30Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![dudenas](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/dudenas/32/276890_2.png) [@dudenas](https://meta.discourse.org/u/dudenas)
#### Post date: [30.Декабрь.2024 18:06:30 UTC](https://meta.discourse.org/t/getting-502-bad-gateway-after-attempting-upgrade/344923/1 "2024-12-30T18:06:30Z")

</div>

Всем привет,

Кажется, я сломал свой сайт, нажав на кнопку «Upgrade» в «Discourse-Manager», если я правильно помню. Система сообщила об ошибке, и я нажал на галочку «reset upgrade» или что-то в этом роде. Точно воспроизвести действия не могу, так как сайт недоступен.

На данный момент я выяснил, что Rails не подключается к Redis, и я не могу пересобрать приложение. Не уверен, как дальше действовать.

**В логе Rails production указано:**  
`Error connecting to Redis on localhost:6379 (Errno::EADDRNOTAVAIL) subscribe failed, reconnecting in 1 second. Call stack /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/redis-4.8.1/lib/redis/client.rb:398:in `rescue in establish\_connection’`

**./launcher rebuild app:**

```plaintext
Error response from daemon: toomanyrequests: Too Many Requests (HAP429).
Error response from daemon: toomanyrequests: Too Many Requests (HAP429).
Unable to find image 'discourse/base:2.0.20241203-0251' locally
docker: Error response from daemon: toomanyrequests: Too Many Requests (HAP429).
See 'docker run --help'.
Your Docker installation is not working correctly

```

---

<div class="post-metadata">

### Author: ![Canapin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/canapin/32/119591_2.png) [@Canapin](https://meta.discourse.org/u/Canapin)
#### Post date: [30.Декабрь.2024 18:25:58 UTC](https://meta.discourse.org/t/getting-502-bad-gateway-after-attempting-upgrade/344923/2 "2024-12-30T18:25:58Z")

</div>

Вы достигли лимита запросов от Docker.

Многие пользователи смогли решить проблему, отключив IPv6.

> <https://github.com/docker/hub-feedback/issues/2421>
>
> Hi,
> 
> Thank you for providing the support to every single case when this appears.…
> 
> In my case it happened all of the sudden, without any changes on sysadmin so I have no idea how to determine if I have a loose script running wild with the requests, would you please be so kind to provide some stats, or possible causes? Project is hosted on VPS.
> 
> I can't docker push anything, not even login or pull:
> 
> \`\`\`
> docker login -u \*\*\*\*
> Password:
> Error response from daemon: login attempt to https://registry-1.docker.io/v2/ failed with status: 429 Too Many Requests
> \`\`\`
> 
> \`\`\`
> docker pull nginx
> Using default tag: latest
> Error response from daemon: toomanyrequests: Too Many Requests (HAP429).
> \`\`\`
> 
> Thank you!

Похожая проблема:

> [@Docker Rate Limit Error on Launcher Rebuild](https://meta.discourse.org/t/docker-rate-limit-error-on-launcher-rebuild/344143/13?u=cocoquark):
>
> Turning off IPv6 on the Digital Ocean server solved the issue: Here is instruction from DO on how to turn off IPv6.

---

<div class="post-metadata">

### Author: ![dudenas](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/dudenas/32/276890_2.png) [@dudenas](https://meta.discourse.org/u/dudenas)
#### Post date: [30.Декабрь.2024 21:57:32 UTC](https://meta.discourse.org/t/getting-502-bad-gateway-after-attempting-upgrade/344923/3 "2024-12-30T21:57:32Z")

</div>

Спасибо, отключение IPv6 помогло!

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [29.Январь.2025 21:58:17 UTC](https://meta.discourse.org/t/getting-502-bad-gateway-after-attempting-upgrade/344923/4 "2025-01-29T21:58:17Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
