# Getting a 403 error popup when trying to admin users

**URL:** https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393
**Category:** Self-hosting
**Created:** [November 6, 2020, 3:51am UTC](https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393 "2020-11-06T03:51:00Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![seeminglee](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/seeminglee/32/199310_2.png) [@seeminglee](https://meta.discourse.org/u/seeminglee)
#### Post date: [November 6, 2020, 3:51am UTC](https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393/1 "2020-11-06T03:51:00Z")

</div>

I’ve just installed discourse on a new server. Things are going great but now I am getting a popup for `403 error` whenever I try to do perform admin tasks:

- editing user / granting moderator status

The errors in the console log are:

```plaintext

PUT https://discuss.royaleapi.com/admin/users/5/grant_moderation 403

SyntaxError: Unexpected token < in JSON at position 0
    at Function.parse [as parseJSON] (<anonymous>)

Uncaught {jqXHR: {…}, textStatus: "error", errorThrown: "", _discourse_displayed: true}

```

Also, I am unable to log out for some reason. I have cleared my browser cache and login fresh but still clicking on the logout link does nothing.

For the log out issue I see this in my console:

```plaintext
includes.js?v=xxxxxxxxxx DELETE https://discuss.royaleapi.com/session/sml 403

ember_jquery-xxxxxxx.js:1 Uncaught {jqXHR: {…}, textStatus: "error", errorThrown: ""}

```

I’ve replaced some of the paths above because I was not sure they are keys or not

---

<div class="post-metadata">

### Author: ![seeminglee](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/seeminglee/32/199310_2.png) [@seeminglee](https://meta.discourse.org/u/seeminglee)
#### Post date: [November 6, 2020, 7:51am UTC](https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393/2 "2020-11-06T07:51:40Z")

</div>

Update: I’ve solved this issue by setting Cloudflare to DNS only mode.

However, is there anyway to proxy over Cloudflare / any settings that would work? I guess I should follow these settings… [https://www.communiteq.com/kb/using-cloudflare/](https://www.communiteq.com/kb/using-cloudflare/)

---

<div class="post-metadata">

### Author: ![michaeld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/michaeld/32/1594_2.png) [@michaeld](https://meta.discourse.org/u/michaeld)
#### Post date: [November 6, 2020, 6:44pm UTC](https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393/3 "2020-11-06T18:44:28Z")

</div>

That document is specifically for clients hosting with us, not a general recommendation for self hosted instances.

As a rule of thumb I would say: stick to DNS only (grey cloud) unless you really know what you are doing.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [November 6, 2020, 6:47pm UTC](https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393/4 "2020-11-06T18:47:52Z")

</div>

> [@michaeld](#):
>
> As a rule of thumb I would say: stick to DNS only (grey cloud) unless you really know what you are doing.

![tenor](https://global.discourse-cdn.com/meta/original/3X/a/1/a19414d2686b09b2786494d6820d5cfa6e23d1be.gif)

---

<div class="post-metadata">

### Author: ![seeminglee](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/seeminglee/32/199310_2.png) [@seeminglee](https://meta.discourse.org/u/seeminglee)
#### Post date: [November 6, 2020, 7:23pm UTC](https://meta.discourse.org/t/getting-a-403-error-popup-when-trying-to-admin-users/169393/5 "2020-11-06T19:23:13Z")

</div>

Noted — we do have to use Cloudflare for our other subdomains 😅
