Getting email every 5 minutes that says "Email issue --Unknown To: Address"

(Channing Hinton) #1

Continuing the discussion from PullHotlinkedImages triggers a “Job exception: failed to allocate memory” error:

(Kane York) #2

So, what is your reply_by_email_address?

(Channing Hinton) #3

reply+%{reply_key} and yes email in is enabled.

(Kane York) #4

Turning off email in will stop the reply spam for now, but I’m not sure how the loop started - the reply address looks right.

(Channing Hinton) #5

That’s what I was asking. Is there a queue that I can clear somewhere?

Turning off email in would stop all communication on this forum. I can’t do that.

(Rogelio J. Samour) #6

@riking: I’m seeing the same issue on my Discourse instance (1.2.0.beta5) as @mochabcha

Should we tag this post as a potential bug? My settings also check out.

One thought I had was disabling the ‘reply by email’ rather than ALL outbound email until we figure out the cause of the loop.

Related: Creating topics by email to or fails with 'Email Issue: Unknown To: Address'

(Kane York) #7

Disable “email in” for a bit and the loop will stop.

(Rogelio J. Samour) #8

@riking: thanks! Yeah, that’s what I already did to temporarily fix the issue.

However, that doesn’t inform me as to why this happened to begin with. :-/ I’ve filed a bug: Infinite loop of: ‘Email issue -- Unknown To: Address’ emails

(Channing Hinton) #9

Does it stop the loop permanently or only while email in is inactive?

(Kane York) #10

Well, the emails should still get marked as read while email in is off, so that should stop the loop.

(Channing Hinton) #11

This was the answer and the loop did stop. I disabled emails for about an hour over the weekend. Thank you.

(Nukeador) #12

We have experienced the very same bug, in our case with “Email issue – Auto Generated Reply” subject from the same email address as the forum email address.

We have set up a filter to delete all emails coming from ourselves (let’s see if this fix it) but it would be great if discourse is able to don’t reply to its own email address creating an infinite loop.

(Jeff Atwood) #13

We made this impossible in the site settings a few weeks ago, as I recall. The from: address and the reply to email cannot be the same.

It never occurred to us, back in the day, that users would make loops here.

(Nukeador) #14

Maybe this change not yet on beta?

(Régis Hanol) #15

That validation was made on Feb, 6th

The issue might be that this validation was not retroactive. Did you set your setting before Feb, 6th?

(Nukeador) #16

Which setting specifically?

(Jeff Atwood) #17

The ones specified in the text above…?

(Nukeador) #18

So yes, I set these settings long time ago before Feb. 6th.

(Peter) #19

Sorry for bumbing this old thread but the stuff here helped me to fix my problem and I just wanted to say that I stumbled over this problem “every 5 minutes several emails” with a recent installation. Though it was my fault: I set up a wrong filter forwarding all emails containing “discuss-management” in the ‘From’ to "" and the contact email was leading to the obvious loop. To fix this I changed the filter to “discuss-management-” (note the ending -) and also changed the contact email to

Only one further time I got these emails with content:

We’re sorry, but your email message to [“”] (titled
[MyDomain] Email issue – Unknown To: Address) didn’t work.

None of the destination addresses are recognized. Please make sure
that the site address is in the To: line (not Cc: or Bcc:), and that you
are sending to the correct email address provided by staff.

What is the real cause for them? Is that just one user with a no longer reachable email?

(Joegoggins) #20

I’m getting multiple messages with different ids like this every 5 minutes from, any suggestions on how to resolve that?

We're sorry, but your email message to [""] (titled Re: [Discourse Meta] Email issue -- Unknown To: Address) didn't work.

None of the destination email addresses are recognized. Please make sure that you are sending to the correct email address provided by staff.