Getting Error on setting up Google Sign-in

I recently added Google+ sign in. And getting this error while signing up with Google.


Please help me

It’s not a good practice to mention people after 20 minutes that you’ve reported a problem, especially on weekends where team members also want to spend time with their families.

That said, did you follow the Configuring Google login for Discourse guide that was recently updated?
Have you updated your site to the latest version available?
On the site logs there are errors related to Google login?

4 Likes

I am so sorry for that, I really apologize and accept my mistake.

And Yes, I followed the exact guide.

Check out /logs on your site - there should be more details on the error there.

3 Likes

Either you haven’t enabled proper APIs in your Google app or your URLs (endpoint etc. ) is set with incorrect scheme. Is force HTTPS enabled and are you using everything in HTTPS urls?

Also, Google is about to discontinue their Google+ API any time so maybe they’re just limiting authentications?

The latest version of Discourse does not depend on Google+ APIs, so this should not be the issue.

2 Likes

No Taylor, @itsbhanusharma is right. I enabled the Google+ API and its working perfect

Thanks Bhanu brother, Its working now, after enabling the Google+ API

What version of Discourse are you using? It is important that you do not rely on the google+ API, since it will be discontinued very soon.

1 Like

Will Google release any alternative to it?

There are already alternatives in place, which we are using in the latest version of Discourse.

If your site didn’t work without google+ enabled, that means you need to update to the latest version of Discourse.

5 Likes