Getting errors when setting up Discourse dev environment on Ubuntu


(Alan Tan) #12

g++ command not found

Seems like the script is missing a dependency?

Someone had the same problem a month ago in the posts above. Scroll up :wink:


(| full stack virgin) #13

oh!..i guess he was unsuccessful or successful?

i hope he was able to succeed so that i can learn from him


(Alan Tan) #15

Seems like he was sucessful after installing build-essentials.

Try running sudo apt-get install build-essentials?


(| full stack virgin) #16

yap. working on it. :smile: thanks man


(| full stack virgin) #17


(| full stack virgin) #18

@techAPJ,

I’m stuck at this part for almost an hour now.


(Sam Saffron) #19

recommend you read up a bit about general rails setup.

your root user does not seem to have access to a pg db on the box called discourse_development

you can confirm that by running

psql discourse_development

Beginners Guide to Install Discourse on Ubuntu for Development
(| full stack virgin) #20

if not for that ning migration script, i wouldnt pursue the hassle of setting up discourse w/ dev environment.
really don’t know how to run mingration script thru production discourse set-up :frowning:


(| full stack virgin) #21

i think i pretty much followed everything, adding “root” user, until i tested the rails server, and visited localhost, but;

i think this journey ends here. there’s nothing else i can do to run this dev environment. :smiley:


(Arpit Jalan) #22

Since you are setting up dev env on a remote server, replace localhost with your server’s IP address. For example: 123.456.78.90:3000


(| full stack virgin) #23

@techAPJ, i’ll look into that. i’ll re-create another droplet.


(| full stack virgin) #24


(Arpit Jalan) #25

Try running the script again, I just made some changes.


(| full stack virgin) #26

i didn’t encounter this error yesterday.


(| full stack virgin) #27

is this okay?


(| full stack virgin) #28


(| full stack virgin) #29


(Blake Erickson) #31

You are probably getting that error because you need to open up port 3000 wherever you are doing your hosting.

You could also try:

rails server -p 80

and then you should just be able to go to navigate to your ip address without the port number.


(Sam Saffron) #32

keep in mind you need to be running as root for that to work…


(| full stack virgin) #33

Thanks for the suggestion guys.