Getting Locked Out From My IP?


(Trent) #1

Hi,

I had everything working fine on a fresh install. Setup SSL and tested it, working fine. I was adding categories to my forum when I accidently closed my browser. AFter i re-open my browser I could access my site.

I getting this error:

ERR_CONNECTION_REFUSED

Not sure if SSL has broken and I cant acces http as it redirects to https.

Here is my ./launcher logs app

 run-parts: executing /etc/runit/1.d/00-ensure-links
    run-parts: executing /etc/runit/1.d/anacron
    run-parts: executing /etc/runit/1.d/cleanup-pids
    Cleaning stale PID files
    run-parts: executing /etc/runit/1.d/copy-env
    run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
    Started runsvdir, PID is 30
    sh: echo: I/O error
    ok: run: redis: (pid 39) 0s
    ok: run: postgres: (pid 41) 0s
    rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? try rsyslog.com/e/3003 
    rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try rsyslog.com/e/2307 ]
    rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try rsyslog.com/e/2039 ]
    2016-01-30 13:29:53 UTC [54-1] LOG:  database system was shut down at 2016-01-30 13:29:21 UTC
    2016-01-30 13:29:53 UTC [54-2] LOG:  MultiXact member wraparound protections are now enabled
    2016-01-30 13:29:53 UTC [41-1] LOG:  database system is ready to accept connections
    2016-01-30 13:29:53 UTC [58-1] LOG:  autovacuum launcher started
    39:M 30 Jan 13:29:53.470 * Redis 3.0.6 (00000000/0) 64 bit, standalone mode, port 6379, pid 39 ready to start.
    39:M 30 Jan 13:29:53.470 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    39:M 30 Jan 13:29:53.471 # Server started, Redis version 3.0.6
    39:M 30 Jan 13:29:53.471 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
    39:M 30 Jan 13:29:53.471 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
    39:M 30 Jan 13:29:53.518 * DB loaded from disk: 0.047 seconds
    39:M 30 Jan 13:29:53.519 * The server is now ready to accept connections on port 6379
    supervisor pid: 40 unicorn pid: 63
    Shutting Down
    run-parts: executing /etc/runit/3.d/01-nginx
    ok: down: nginx: 0s, normally up
    run-parts: executing /etc/runit/3.d/02-unicorn
    exiting
    ok: down: unicorn: 0s, normally up
    run-parts: executing /etc/runit/3.d/10-redis
    39:signal-handler (1454160742) Received SIGTERM scheduling shutdown...
    39:M 30 Jan 13:32:22.622 # User requested shutdown...
    39:M 30 Jan 13:32:22.622 * Saving the final RDB snapshot before exiting.
    392016-01-30 13:32:22 UTC [41-2] LOG:  received smart shutdown request
    :signal-handler (1454160742) Received SIGTERM scheduling shutdown...
    39:signal-handler (1454160742) Received SIGTERM scheduling shutdown...
    2016-01-30 13:32:22 UTC [58-2] LOG:  autovacuum launcher shutting down
    Terminated
    Shutting Down
    2016-01-30 13:32:22 UTC [55-1] LOG:  shutting down
    2016-01-30 13:32:22 UTC [55-2] LOG:  database system is shut down
    run-parts: executing /etc/runit/3.d/01-nginx
    fail: nginx: runsv not running
    run-parts: /etc/runit/3.d/01-nginx exited with return code 1
    run-parts: executing /etc/runit/3.d/02-unicorn
    fail: unicorn: runsv not running
    run-parts: /etc/runit/3.d/02-unicorn exited with return code 1
    run-parts: executing /etc/runit/3.d/10-redis
    39:M 30 Jan 13:32:22.789 * DB saved on disk
    39:M 30 Jan 13:32:22.789 # Redis is now ready to exit, bye bye...
    fail: redis: runsv not running
    run-parts: /etc/runit/3.d/10-redis exited with return code 1
    run-parts: executing /etc/runit/3.d/99-postgres
    fail: postgres: runsv not running
    run-parts: /etc/runit/3.d/99-postgres exited with return code 1
    fail: cron: runsv not running
    fail: nginx: runsv not running
    fail: postgres: runsv not running
    fail: redis: runsv not running
    fail: rsyslog: runsv not running
    fail: unicorn: runsv not running
    /sbin/boot: line 9: kill: (30) - No such process
    run-parts: executing /etc/runit/1.d/00-ensure-links
    run-parts: executing /etc/runit/1.d/anacron
    run-parts: executing /etc/runit/1.d/cleanup-pids
    Cleaning stale PID files
    run-parts: executing /etc/runit/1.d/copy-env
    run-parts: executing /etc/runit/1.d/ensure-web-nginx-read
    Started runsvdir, PID is 21
    sh: echo: I/O error
    ok: run: redis: (pid 31) 0s
    ok: run: postgres: (pid 33) 0s
    rsyslogd: invalid or yet-unknown config file command 'KLogPermitNonKernelFacility' - have you forgotten to load a module? [try http://www.rsyslog.com/e/3003 ]
    31:M 30 Jan 13:32:32.315 * Redis 3.0.6 (00000000/0) 64 bit, standalone mode, port 6379, pid 31 ready to start.
    rsyslogd: warning: ~ action is deprecated, consider using the 'stop' statement instead [try http://www.rsyslog.com/e/2307 ]
    31:M 30 Jan 13:32:32.338 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    31:M 30 Jan 13:32:32.338 # Server started, Redis version 3.0.6
    31:M 30 Jan 13:32:32.339 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
    31:M 30 Jan 13:32:32.345 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
    rsyslogd: Could no open output pipe '/dev/xconsole': No such file or directory [try rsyslog.com/e/2039 ]
    31:M 30 Jan 13:32:32.462 * DB loaded from disk: 0.117 seconds
    31:M 30 Jan 13:32:32.465 * The server is now ready to accept connections on port 6379
    2016-01-30 13:32:32 UTC [48-1] LOG:  database system was shut down at 2016-01-30 13:32:22 UTC
    2016-01-30 13:32:32 UTC [48-2] LOG:  MultiXact member wraparound protections are now enabled
    2016-01-30 13:32:32 UTC [33-1] LOG:  database system is ready to accept connections
    2016-01-30 13:32:32 UTC [52-1] LOG:  autovacuum launcher started
    supervisor pid: 32 unicorn pid: 54
    31:M 30 Jan 13:37:33.092 * 10 changes in 300 seconds. Saving...
    31:M 30 Jan 13:37:33.095 * Background saving started by pid 431
    431:C 30 Jan 13:37:33.137 * DB saved on disk
    431:C 30 Jan 13:37:33.137 * RDB: 12 MB of memory used by copy-on-write
    31:M 30 Jan 13:37:33.196 * Background saving terminated with success

any help would be great.


(Sam Saffron) #2

Sounds to me like someone ran docker stop on your container.

Were you running an OS upgrade at the time?

Can you reproduce this issue?


(Trent) #3

Hey,

No, i don’t think I ran an update. Checked status of docker:

sudo service docker status
docker start/running, process 844

It started working again briefly. Now it might be that my IP is getting blocked because I can get to my site via my phone 4G fine without any issues, but my home wifi seems to be sporadic. Is there anything that could be causing this?

Cheers Sam.


(Trent) #4

I just connected my computer on wifi to a VPN and now can access my forum again. Seams like my home ISP IP is being blocked.