# 主机名更改后出现幽灵主机名

**URL:** https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353
**Category:** Support
**Created:** [2022年十月8日 17:37 UTC](https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353 "2022-10-08T17:37:04Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![johnknapp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/johnknapp/32/275917_2.png) [@johnknapp](https://meta.discourse.org/u/johnknapp)
#### Post date: [2022年十月8日 17:37 UTC](https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353/1 "2022-10-08T17:37:04Z")

</div>

你好，一位新的 Discourse 用户。 👋

**问题陈述：**

1. 安装和设置后，在进行所有必要的更改后，我更改了域名。（Cloudflare DNS、app.yml、droplet 主机名、新的 SSL 证书、重建 docker 等等。）
2. 一切正常
3. **直到：** 激活 S3 备份时，访问 /admin/backups 会产生 500 错误
4. /admin/logs 报告 `certificate verify mismatch (Hostname mismatch)`
5. 切换回本地备份后一切正常。

**问题：**

- 原始主机名可能隐藏在哪里？ _我知道你不能告诉我我忘了什么，所以也许你可以列出这些设置所在的位置。_

**供参考：**

```plaintext
Seahorse::Client::NetworkingError (SSL_connect returned=1 errno=0 peeraddr=162.243.189.2:443 state=error: certificate verify failed (Hostname mismatch))
lib/s3_helper.rb:426:in `s3_bucket'
lib/s3_helper.rb:240:in `list'
lib/backup_restore/s3_backup_store.rb:122:in `unsorted_files'
lib/backup_restore/backup_store.rb:23:in `files'
app/controllers/admin/backups_controller.rb:24:in `block (2 levels) in index'
app/controllers/admin/backups_controller.rb:13:in `index'
app/controllers/application_controller.rb:412:in `block in with_resolved_locale'
app/controllers/application_controller.rb:412:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:71:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:368:in `call'
config/initializers/100-quiet_logger.rb:23:in `call'
config/initializers/100-silence_logger.rb:31:in `call'
lib/middleware/enforce_hostname.rb:23:in `call'
lib/middleware/request_tracker.rb:202:in `call'

```

- 域名从 [bolderfounders.com](http://bolderfounders.com) 更改为 [smarterfounders.com](http://smarterfounders.com)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2022年十月9日 11:00 UTC](https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353/2 "2022-10-09T11:00:06Z")

</div>

请参阅[更改域名或重命名 Discourse](https://meta.discourse.org/t/change-the-domain-name-or-rename-your-discourse/16098)。确保 Cloudflare 仅用于 DNS。

---

<div class="post-metadata">

### Author: ![johnknapp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/johnknapp/32/275917_2.png) [@johnknapp](https://meta.discourse.org/u/johnknapp)
#### Post date: [2022年十月9日 18:05 UTC](https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353/3 "2022-10-09T18:05:56Z")

</div>

感谢 Jay 提供链接。我还没有找到那个话题。🙂

根据你的输入和那个链接的话题，我已经：

1. 禁用了 Cloudflare，并通过 [DNSChecker.org](http://DNSChecker.org) 确认我的 A 记录解析到我的 DO 滴管 IP
2. 仔细检查了我的 app.yml（它没问题）
3. 进入了 app 容器并从旧域名运行了 `discourse remap` 到新域名，它进行了更改。为了确认，我第二次运行它，它没有更改就退出了
4. 使用递归 grep 在 app 容器内外搜索旧域名，但一无所获
5. 重建了 app 并研究了 docker run 命令。没有发现问题。
6. 进入我的管理员界面，将备份从本地更改为 S3
7. 继续收到之前的 500 错误。😿
8. 改回本地备份，一切又恢复正常。
9. 启用了 Cloudflare 并再次确认它正在代理
10. 我感到卡住了，基本上是 🤷‍♂️

---

<div class="post-metadata">

### Author: ![johnknapp](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/johnknapp/32/275917_2.png) [@johnknapp](https://meta.discourse.org/u/johnknapp)
#### Post date: [2022年十月10日 15:51 UTC](https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353/4 "2022-10-10T15:51:19Z")

</div>

_奥卡姆剃刀_

**已解决：**

- 在 `/admin/site_settings/category/files`
- s3 端点不应包含存储桶名称 🤦

回想起来很明显

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [2022年十一月9日 15:52 UTC](https://meta.discourse.org/t/ghost-hostname-after-hostname-change/241353/5 "2022-11-09T15:52:17Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
