GitHub did not send all necessary objects


(Hecbuma) #1

I’m added a pluging to my app.yml and the time I do ./launcher bootstrap app it fails this is the log

[168] 05 Aug 19:34:44.366 # Server started, Redis version 2.8.9
[168] 05 Aug 19:34:44.367 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
[168] 05 Aug 19:34:44.376 * DB loaded from disk: 0.009 seconds
[168] 05 Aug 19:34:44.376 * The server is now ready to accept connections on port 6379
I, [2014-08-05T19:34:45.145478 #36]  INFO -- : HEAD is now at b85c78a return unescaped HTML here

I, [2014-08-05T19:34:45.146220 #36]  INFO -- : > cd /var/www/discourse && git clean -f
I, [2014-08-05T19:34:45.177419 #36]  INFO -- : Not removing vendor/bundle/

I, [2014-08-05T19:34:45.177712 #36]  INFO -- : > cd /var/www/discourse && git pull
error: Could not read 6b5d9a1ede96e73d14cfa732e9370180ff28814d
fatal: revision walk setup failed
error: https://github.com/discourse/discourse.git did not send all necessary objects

I, [2014-08-05T19:34:48.969722 #36]  INFO -- :
2014-08-05 19:34:48 UTC LOG:  received smart shutdown request
[168 | signal handler] (1407267288) Received SIGTERM, scheduling shutdown...
2014-08-05 19:34:48 UTC LOG:  autovacuum launcher shutting down
2014-08-05 19:34:48 UTC LOG:  shutting down
[168] 05 Aug 19:34:48.975 # User requested shutdown...
[168] 05 Aug 19:34:48.976 * Saving the final RDB snapshot before exiting.
2014-08-05 19:34:48 UTC LOG:  database system is shut down
[168] 05 Aug 19:34:48.990 * DB saved on disk
[168] 05 Aug 19:34:48.990 # Redis is now ready to exit, bye bye...
/pups/lib/pups/exec_command.rb:85:in `spawn': cd /var/www/discourse && git pull failed with return #<Process::Status: pid 174 exit 1> (RuntimeError)
	from /pups/lib/pups/exec_command.rb:55:in `block in run'
	from /pups/lib/pups/exec_command.rb:53:in `each'
	from /pups/lib/pups/exec_command.rb:53:in `run'
	from /pups/lib/pups/command.rb:6:in `run'
	from /pups/lib/pups/config.rb:85:in `block (2 levels) in run_commands'
	from /pups/lib/pups/config.rb:76:in `each'
	from /pups/lib/pups/config.rb:76:in `block in run_commands'
	from /pups/lib/pups/config.rb:75:in `each'
	from /pups/lib/pups/config.rb:75:in `run_commands'
	from /pups/lib/pups/config.rb:71:in `run'
	from /pups/lib/pups/cli.rb:31:in `run'
	from /pups/bin/pups:8:in `<main>'
e184b0b261da24fbeb8b548e716cb19cea0401a13ad2c899907e5daaf01fc8e6
FAILED TO BOOTSTRAP

this my docker version
docker --version
Docker version 0.11.1, build fb99f99

any clues?

thanks.


(Sam Saffron) #2

I would try a rebuild, looks like a comms issue with github.

cd /var/docker
git pull
./launcher rebuild app

(Hecbuma) #3

Thanks that works.
is there any data loss or down side of doing a “rebuild”?


(Sam Saffron) #4

Nope, zero data loss.