Gmail new account creation flow broken when 2FA is enabled?


(Michael Brown) #1

On Chrome/Linux, when logging into try (and creating an account) from incognito on an account that has 2FA enabled, I get this after authenticating to Google:

If I close the window then click ‘Google’ again, everything works as normal


(Jeff Atwood) #2

No repro in Chrome / Windows – I can log in fine to try.discourse.org with 2 factor. This must be platform or browser specific somehow.

Or wait… you are referring to creating a new account?


(Michael Brown) #3

Yes - it happens when logging in & needing to create an account at the same time.


(Jeff Atwood) #4

I can’t repro any problems with creating a new account in Windows/Chrome via Google login… I got to here just fine in an incognito window using my Google credentials plus the Google authenticator app:

After clicking Create New Account I was in.

… so I am going back again to “something platform or browser specific is somehow bad here”.

When you say 2FA you mean the Google Authenticator smartphone app, yes, not a yubikey or anything like that?


(Michael Brown) #5

I have a yubikey but bypassed it to use my 2FA app TOTP code. I’ll try varying the 2FA method and Linux/Windows and see if I get the same behaviour.

EDIT:

  • Chrome 64.0.3282.167/Windows/Yubikey: OK
  • Chrome/Windows/App: OK
  • Chrome 63.0.3239.132/Linux/Yubikey: Nope
  • Chrome/Linux/App: Nope
  • Firefox/Linux/Yubikey: (failure - Firefox couldn’t use it)
  • Firefox/Linux/App: OK