Google Login Stopped Working

I started getting this error with my Google OAuth

Sorry, there was an error authorizing your account. Perhaps you did not approve authorization?

I tried various troubleshooting methods, to the extent of creating new Oauth2 tokens

following the instructions verbatim

But, I still get the same error.

Note: I logged to this forum using my Google Authentication, so it is definitely do with some configuration of mine.

Any suggestions?

  • Are we still needing to toggle between Google+ API Enable vs Disable?
  • Where can I more information on the login failure?

Looking at the error you’ve mentioned, most probably it is related to the authorised redirect … Can you confirm that you set it properly?

Since Google is killing their G+ api the instructions have been changed to work without depending on it.

2 Likes

Are you using the latest version of Discourse? Older versions relied on google+ API, which is being shut down

APIs starting to intermittently fail as early as January 28, 2019

6 Likes

Perhaps, I have a reason why my google sign in requests are failing!
Screenshot_2019-01-31%20Consent%20screen%20-%20orngCentral%20-%20Google%20Cloud%20Platform

Because you updated the application logo, your consent screen requires verification by Google

Screenshot_2019-01-31%20Consent%20screen%20-%20orngCentral%20-%20Google%20Cloud%20Platform(1)

Seems like my application is pending verification because I uploaded a logo. It clearly states that once I submit application for approval, it can take several weeks.

5 Likes

I am on the latest version, 2.2.0.beta10 as of January 31st.

  • For the users who were already logged in, Google oauth2 seems to be working.
  • If I logged out, and I am unable to login back.

I followed the discourse documentation, and verified my settings (redirect URL), and nothing seems to be off.