Group flairs not showing up

I have a group called Directors and set up my flair as such:
image fa-crown
background ffffff
color f803fc

The preview shows it correctly:
image

However, when I go to post- it does not show it correctly (note that I have my title set to the group)

Help would be appreciated. Thanks!

It needs to be your primary group.

How do you set your Primary Group? Is it the same as setting your title to a group’s?

I think it’s https://meta.discourse.org/my/preferences/account and find “title”.

I’ve set my title to the group and it’s still not showing the flair.

Do others in the same group get the flair? Or is there any other group that sets flair correctly?

I suspect this can be theme related.

I’m using the Material theme. After changing to the default light theme and clearing the cache, the flair still does not appear.

Another account, with TL4 and the sole group has a flair (see below) had this result:

n.b. the title is Official Account as this group does not have a title

The group’s flair info:

icon fa-gaven
background ffffff
color 000000

None of the groups have their flair showing correctly from my testing.

Mind giving this a shot?

Just enable the primary group setting once

1 Like

It works now, thanks!

Slight problem: I have overlapping groups. Is there a way for an end user to manually set their primary group?

EDIT: I found I was able to set a priority system by turning the box on in order. Not ideal, but works none the less.

1 Like

I’m not exactly sure about this.
Most probably there should be a way for users to do that but I’m struggling to find that.

1 Like

There’s a setting in user admin under custom groups.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.