Groups not included in user export


(Jason Ives) #1

Some time ago I requested that group membership be included in the CSV export of users – this wish was quickly granted with a PR from techAPJ and all seemed to be well.

I am running discourse 1.1.0.beta6b and exported users are not in the CSV output – looking at exports back to 1.0 I’ve not had them in the CSV; I don’t have any older exports on hand but I can’t remember the feature actually working for me.


(Tobias Eigen) #2

actually this is not true - I just tried it on my forum and it includes groups with the export, in the 4th column separated by semicolons. good feature!


(Jason Ives) #3

Interesting – it’s definitely not working for me but if it’s just me I can perform a fresh install and restore from backup to eliminate whatever oddity is breaking my install.

Thanks.


(Jason Ives) #4

Re-categorized as support (was bug) as it’s working for @tobiaseigen but not for me.

Rebuilt discourse docker thinking that would surely fix the issue for me, though I believe I’d done that when upgrading to 1.0… still not working. I get three columns but not the fourth. export_csv_file.rb definitely shows the code to add groups to the output… not sure how to proceed in order to find the source of the issue; any suggestions would be appreciated.


(Tobias Eigen) #5

are you sure you have groups on your site? Note that the export only includes groups you’ve manually created and not trust levels, admins, mdoerators etc.


(Jason Ives) #6

Yes, I have defined a number of groups (and almost all members belong to at least one of them). No user has a groups column in my csv – and I checked the file in a text editor to make sure excel wasn’t doing something funky.


(Tobias Eigen) #7

and you’re talking about the Export Users feature on the admin user list?


(Jason Ives) #8

Yes… I am talking about the export users feature on the admin user list.


(Jason Ives) #9

I moved my forum from a standalone configuration to separate data/web containers today; two new containers created as a result with the forum restored using discourse’s backup/restore feature – that went quite nicely!

Still no groups on user export, though. Error logs (within discourse) don’t show anything… any suggestions @techAPJ? :frowning:


(Spero Koulouras) #10

I can confirm that we have the same issue. I have a manually created group with about 70 users in it and they don’t show up on export.


(Arpit Jalan) #11

Until now default and invisible groups were not being included in user CSV export file, fixed that:

https://github.com/discourse/discourse/commit/8b56c16e1486

Could you please update your Discourse instance and try exporting again? This should be fixed now.


(Jason Ives) #12

Now working as expected, thank you!


(Jeff Atwood) #13