Halp! Error response from daemon


(laRoux87) #1

Hello! Discourse has been working great for months, then went down and I have been struggling to get my forums back online since. I’ve been working with a friend who also uses Discourse, but he’s gotten too busy and can’t remember what the error I’m receiving means:

2014/10/19 01:40:54 Error response from daemon: client and server don’t have same version (client : 1.14, server: 1.12)

If anyone could at least point me in the right direction I’d greatly appreciate the assist. I’m new to all of this, so please bear with me if this is something painfully obvious.


(Jeff Atwood) #2

Is this a docker based install? Standard advice applies. Log in at console, cd /var/discourse, git pull, ./launcher rebuild app.


(laRoux87) #3

Yes, it is. And I get the same error when I try git pull, then ./launcher rebuild app


(Jeff Atwood) #4

Can you google that error? Is Docker not installed correctly? Maybe uninstall and reinstall Docker.


(laRoux87) #5

I’ve tried googling it and didn’t find anything. I’ve also tried googling just little chunks of it looking for anything to try but no luck. I can try uninstalling and reinstalling… I was just hoping to avoid it.


(laRoux87) #6

I reinstalled and it’s now back up! Thanks for the help :slight_smile:


(Sam Saffron) #7