Hard time setting up the SMTP


#1

Hi everyone,

I’m new here and new to Discourse but it looks awesome! Anyways, I’ve installed it but I’m having so much trouble getting the SMTP to work… My host is Bluehost. I tried so many different ways:

Mail server: mail.fragnet.ca (also tried box834.bluehost.com)
Post: 26 (also tried 465)

But I’m always getting this error:

Jobs::HandledExceptionWrapper: Wrapped OpenSSL::SSL::SSLError: hostname “mail.fragnet.ca” does not match the server certificate

This is the info given to me by the Bluehost support.

My install: http://104.248.112.182

Is it because the install is not on the Bluehost box?

What am I doing wrong?

Thank you for your help and time!


(Matt Palmer) #2

Fix the SMTP server configuration such that the name you connect with matches the name in the certificate presented.


#3

Hi Matt, thanks for taking the time to reply. After reading a few threads I decided to switch for Mailgun. I got everything set up properly and no errors in the admin panel this time. But unfortunately I’m still not receiving the emails. I included screenshots showing everything looks configured properly. But still not working. I’m pretty bummed out. I’ll keep trying to figure it out tomorrow but if you or anyone else have any suggestion I’m all ears. Thank you for your time.


(Matt Palmer) #4

You want this topic.


#5

Looking at it now, thank you.


#6

Haven’t figured it out yet. But I found this error log in the Mailgun admin panel:


(Matt Palmer) #7

Fix the DMARC policy for do.co.


#8

Brilliant! Working now! Thank you so much Matt I really appreciate it :facepunch:

Didn’t spot that option in the ACP. Spent too much time in the console.


(Jeff Atwood) #9