# Ajuda após atualização do site ssh cair

**URL:** https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499
**Category:** Self-hosting
**Created:** [30 Janeiro , 2022 17:16 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499 "2022-01-30T17:16:07Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![kynic](https://avatars.discourse-cdn.com/v4/letter/k/b487fb/32.png) [@kynic](https://meta.discourse.org/u/kynic)
#### Post date: [30 Janeiro , 2022 17:16 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/1 "2022-01-30T17:16:07Z")

</div>

Segui isto e atualizei o discourse via ssh

> [@Manually update Discourse and Docker image to latest](https://meta.discourse.org/t/how-do-i-manually-update-discourse-and-docker-image-to-latest/23325):
>
> bookmark This guide provides step-by-step instructions for manually updating Discourse, the Docker container, and the Ubuntu operating system on a self-hosted setup. person_raising_hand Required user level: System Administrator warning SSH access to the server. If you self-host Discourse, you occasionally need to run a manual update via the command line to get the latest security releases newest libraries. These updates are not picked up in admin/update, which is why you’ll occasiona…

Depois de fazer isso, o site cai, por favor me ajude, estou estressado, por favor ajude

ele mostra isto quando tento iniciar o launcher

```plaintext
./launcher start app
x86_64 arch detected.

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: sethostname: invalid argument: unknown
Error: failed to start containers: app

```

---

<div class="post-metadata">

### Author: ![tobiaseigen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tobiaseigen/32/539204_2.png) [@tobiaseigen](https://meta.discourse.org/u/tobiaseigen)
#### Post date: [30 Janeiro , 2022 18:09 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/9 "2022-01-30T18:09:33Z")

</div>

Tente isto em vez disso:

```plaintext
cd /var/discourse
git pull
./launcher rebuild app

```

---

<div class="post-metadata">

### Author: ![kynic](https://avatars.discourse-cdn.com/v4/letter/k/b487fb/32.png) [@kynic](https://meta.discourse.org/u/kynic)
#### Post date: [30 Janeiro , 2022 18:12 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/10 "2022-01-30T18:12:51Z")

</div>

Já fiz, continua o mesmo;

git pull  
`Already up to date.`

./launcher rebuild app  
no final, isso aparece:

```plaintext
 ess 02:fc:33:3e:fd:f6 local_discourse/app /sbin/boot
589988dcb7e5e026f29b8af3b507e51a260e9de2f1ddfaea0620e1fbd2ea80e7
docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: sethostname: invalid argument: unknown.

```

---

<div class="post-metadata">

### Author: ![tobiaseigen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tobiaseigen/32/539204_2.png) [@tobiaseigen](https://meta.discourse.org/u/tobiaseigen)
#### Post date: [30 Janeiro , 2022 18:15 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/11 "2022-01-30T18:15:20Z")

</div>

Você tentou o Discourse Doctor?

> [@Announcing Discourse Doctor](https://meta.discourse.org/t/announcing-discourse-doctor/92991?u=tobiaseigen):
>
> Following the example from [Discourse-doctor woman_health_worker](https://meta.discourse.org/t/discourse-doctor/65169), I’ve created discourse-doctor, now included in discourse\_docker. If you run ./discourse-doctor, you’ll see something like: DISCOURSE DOCTOR Tue Jul 24 08:50:32 UTC 2018 OS: Linux twonames 4.4.0-130-generic #156-Ubuntu SMP Thu Jun 14 08:53:28 UTC 2018 x86\_64 x86\_64 x86\_64 GNU/Linux Found containers/app.yml ==================== YML SETTINGS ==================== DISCOURSE\_HOSTNAME=twonames.ltcmp.net SMTP\_ADDRESS=mail.domain.com DEVELOPER\_EMAILS=…

---

<div class="post-metadata">

### Author: ![kynic](https://avatars.discourse-cdn.com/v4/letter/k/b487fb/32.png) [@kynic](https://meta.discourse.org/u/kynic)
#### Post date: [30 Janeiro , 2022 18:23 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/12 "2022-01-30T18:23:48Z")

</div>

Acabei de fazer isso depois que você disse isso, o que eu recebo nas linhas finais:

```plaintext
sudo: unable to resolve host discourse-ubuntu-s-1vcpu-1gb-nyc1-01-1606640043912-s-2vcpu-4gb-n: Name or service not known
Error response from daemon: Container 387d78b520911e93647a157c578f479a9b4ceaf4fef60b19c638a03de162444c is not running

Replacing: SMTP_PASSWORD
Replacing: LETSENCRYPT_ACCOUNT_EMAIL
Replacing: DEVELOPER_EMAILS
Replacing: DISCOURSE_DB_PASSWORD
Replacing: Sending mail to

==================== DONE! ====================

```

---

<div class="post-metadata">

### Author: ![tobiaseigen](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tobiaseigen/32/539204_2.png) [@tobiaseigen](https://meta.discourse.org/u/tobiaseigen)
#### Post date: [30 Janeiro , 2022 18:30 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/13 "2022-01-30T18:30:31Z")

</div>

E então você reconstrói novamente e o que acontece?

---

<div class="post-metadata">

### Author: ![kynic](https://avatars.discourse-cdn.com/v4/letter/k/b487fb/32.png) [@kynic](https://meta.discourse.org/u/kynic)
#### Post date: [30 Janeiro , 2022 19:29 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/14 "2022-01-30T19:29:15Z")

</div>

Eu alterei o nome do host para ‘discourse-ubuntu’, antes era um nome longo, editando estes arquivos…

`nano /etc/hostname`

discourse-ubuntu

`nano etc/hosts`

```
127.0.1.1 discourse-ubuntu
127.0.0.1 localhost

```

depois disso, reiniciei e reconstruí, e então finalmente funcionou. 😀

Obrigado por toda a ajuda. 🙂

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [1 Março , 2022 19:29 UTC](https://meta.discourse.org/t/help-after-updating-from-ssh-site-goes-down/216499/15 "2022-03-01T19:29:24Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
