Help API error when update from 2.1.0.beta4 to 2.1.0.beta5


(Hình Sỹ Mô) #1

I update from 2.1.0.beta4 to 2.1.0.beta5

error: The underlying connection was closed: An unexpected error occurred on a send.

Help me !


(Sam Saffron) #2

Try upgrading from the console:

cd /var/discourse
./launcher rebuild app

(Hình Sỹ Mô) #3

Thank ! I try upgrading from the console but is not ok


(Sam Saffron) #4

You are going to need to post the errors from the upgrade logs, also try running discourse doctor, maybe you are out of space


(Jared Needell) #5

Anyone find a fix for this? I usually upgrade every 6 months and I noticed all my API integrations are broken. If I run an API call from a browser there’s a response but the same thing in a curl or Invoke-WebRequest I got Invoke-WebRequest : The underlying connection was closed: An unexpected error occurred on a send.


(Blake Erickson) #6

Can you give an example api request that is not working?


(Tim Sawyer) #7

My update failed. See attached screenshot. Console upgrade was successful. Thank you @sam