# Help! Problem with firewall/permissions and postgre?

**URL:** https://meta.discourse.org/t/help-problem-with-firewall-permissions-and-postgre/188927
**Category:** Self-hosting
**Created:** [May 2, 2021, 9:41pm UTC](https://meta.discourse.org/t/help-problem-with-firewall-permissions-and-postgre/188927 "2021-05-02T21:41:07Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![laurakowa](https://avatars.discourse-cdn.com/v4/letter/l/eada6e/32.png) [@laurakowa](https://meta.discourse.org/u/laurakowa)
#### Post date: [May 2, 2021, 9:41pm UTC](https://meta.discourse.org/t/help-problem-with-firewall-permissions-and-postgre/188927/1 "2021-05-02T21:41:07Z")

</div>

Hi!

This is my first official post as I usually just lurk and hunt for the answers, but this one is really stumping me. I recently updated our discourse after a bit via ssh and I’m having trouble getting the forum to connect to the internet and resolve the host. There are some issues with the postgres that I don’t really understand – getting the “not shut down cleanly” message in the FAQ of the [PostgreSQL 12 update](https://meta.discourse.org/t/postgresql-12-update/151236) post.

There’s also an issue with docker (maybe?) that’s preventing me from starting the app and running as suggested.

This is the error that I’m getting with the postgres –

```
The source cluster was not shut down cleanly.

Failure, exiting

-------------------------------------------------------------------------------------

UPGRADE OF POSTGRES FAILED

Please visit https://meta.discourse.org/t/postgresql-13-update/172563 for support.

You can run ./launcher start app to restart your app in the meanwhile

FAILED

--------------------

Pups::ExecError: /root/upgrade_postgres failed with return #<Process::Status: pid 47 exit 1>

Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'

exec failed with the params "/root/upgrade_postgres"

49554f9dc370e42c8989a7e23a8cb30fb06c5857aac7b8a95acb1a0cc21cefff

**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.

./discourse-doctor may help diagnose the problem.

```

And when I try to start the app as suggested –

```
Unable to find image 'local_discourse/app:latest' locally

docker: Error response from daemon: pull access denied for local_discourse/app, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.

See 'docker run --help'.

```

Is there any way to fix this? I feel like I can’t fix the postgres without a running app, and I can’t figure out how to fix the docker/daemon/firewall issue

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [May 3, 2021, 12:19am UTC](https://meta.discourse.org/t/help-problem-with-firewall-permissions-and-postgre/188927/2 "2021-05-03T00:19:52Z")

</div>

Have a look at [PostgreSQL 13 update](https://meta.discourse.org/t/postgresql-13-update/172563).

You need to rebuild a couple of times. Sometimes people just didn’t know to rebuild again and it worked. Sometimes (but not often) there’s something more difficult.

Worst case you can make a new install and restore the backup.

---

<div class="post-metadata">

### Author: ![laurakowa](https://avatars.discourse-cdn.com/v4/letter/l/eada6e/32.png) [@laurakowa](https://meta.discourse.org/u/laurakowa)
#### Post date: [May 3, 2021, 1:26am UTC](https://meta.discourse.org/t/help-problem-with-firewall-permissions-and-postgre/188927/3 "2021-05-03T01:26:10Z")

</div>

Thanks for responding! I have tried rebuilding multiple times, and it’s still failing with the same errors. tbh, I inherited this from someone else, so I’m kind of fumbling around in the dark over here.

I tried backing up via ssh using ./launcher enter app and get another error:

```
root@newforum:/var/discourse# ./launcher enter app
Error: No such container: app

```

I definitely didn’t delete it because I don’t know how to do that. Any ideas?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [May 3, 2021, 1:50am UTC](https://meta.discourse.org/t/help-problem-with-firewall-permissions-and-postgre/188927/4 "2021-05-03T01:50:37Z")

</div>

I’ve seen one upgrade where there was some permissions issue. I can’t remember quite how I fixed it. But maybe you can rename the backup postgres directory, start it back up, make a backup, then start with a fresh install and restore it.
