# Help .. rebuild app failed

**URL:** https://meta.discourse.org/t/help-rebuild-app-failed/84538
**Category:** Self-hosting
**Created:** [April 4, 2018, 7:20am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538 "2018-04-04T07:20:22Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 7:20am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/1 "2018-04-04T07:20:22Z")

</div>

help .. I did a ./launcher rebuild app today, as I have many times before.  
got an error …  
any ideas? looks like something is up with ruby libraries ?

```
I, [2018-04-04T07:06:26.498684 #16] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
rake aborted!
LoadError: /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer_extension.so: undefined symbol: _ZTIN2v811ArrayBuffer9AllocatorE - /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer_extension.so
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:292:in `require'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:292:in `block in require'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:258:in `load_dependency'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:292:in `require'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer.rb:2:in `<top (required)>'
/var/www/discourse/config/application.rb:22:in `<top (required)>'
/var/www/discourse/Rakefile:5:in `require'
/var/www/discourse/Rakefile:5:in `<top (required)>'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/rake-12.1.0/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
(See full trace by running task with --trace)
I, [2018-04-04T07:06:34.391071 #16] INFO -- :
I, [2018-04-04T07:06:34.391568 #16] INFO -- : Terminating async processes
I, [2018-04-04T07:06:34.391658 #16] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/10/bin/postmaster -D /etc/postgresql/10/main pid: 47
I, [2018-04-04T07:06:34.391753 #16] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 163
2018-04-04 07:06:34.391 UTC [47] LOG: received fast shutdown request
163:signal-handler (1522825594) Received SIGTERM scheduling shutdown...
2018-04-04 07:06:34.399 UTC [47] LOG: aborting any active transactions
2018-04-04 07:06:34.403 UTC [47] LOG: worker process: logical replication launcher (PID 56) exited with exit code 1
2018-04-04 07:06:34.404 UTC [51] LOG: shutting down
163:M 04 Apr 07:06:34.427 # User requested shutdown...
163:M 04 Apr 07:06:34.427 * Saving the final RDB snapshot before exiting.
2018-04-04 07:06:34.478 UTC [47] LOG: database system is shut down
163:M 04 Apr 07:06:34.479 * DB saved on disk
163:M 04 Apr 07:06:34.479 # Redis is now ready to exit, bye bye...

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 14253 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development --retry 3 --jobs 4'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
2f3c9493bf73510eacd5441b9b5a42b09def51babd56ee00a35941442da2cc5e
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

---

<div class="post-metadata">

### Author: ![swarnava](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/swarnava/32/120151_2.png) [@swarnava](https://meta.discourse.org/u/swarnava)
#### Post date: [April 4, 2018, 7:28am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/2 "2018-04-04T07:28:02Z")

</div>

Hey Paul,

Are you using any custom plugin?

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 7:42am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/3 "2018-04-04T07:42:15Z")

</div>

I have disabled all but the basics:

```
      - git clone https://github.com/discourse/docker_manager.git
        # - git clone https://github.com/davidtaylorhq/discourse-whos-online.git
      - git clone https://github.com/discourse/discourse-spoiler-alert.git
      - git clone https://github.com/discourse/discourse-cakeday.git
        #- git clone https://github.com/angusmcleod/discourse-events.git
        #- git clone https://github.com/angusmcleod/discourse-locations.git
        # - git clone https://github.com/discourse/discourse-tooltips.git
        # - git clone https://github.com/discourse/discourse-push-notifications.git
        # - git clone https://github.com/communiteq/discourse-sitemap.git

```

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 7:43am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/4 "2018-04-04T07:43:19Z")

</div>

is there an installation log file? that might have more info?

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 8:13am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/5 "2018-04-04T08:13:17Z")

</div>

> [@Docker base image with PostgreSQL 10 released](https://meta.discourse.org/t/docker-base-image-with-postgresql-10-released/84536):
>
> launcher has been updated to use the new [Docker base image](https://hub.docker.com/r/discourse/base/tags/) and [postgres.template.yml](https://github.com/discourse/discourse_docker/blob/44f132443bdf72dccf07111832de4c15b5e8abf8/templates/postgres.template.yml) which would use PostgreSQL 10 by default instead of Postgres 9.5. As long as your container’s config is using the default postgres.template.yml, the upgrade of the PostgreSQL data directory would happen automatically the next time you do a ./launcher rebuild. In the event that the PostgreSQL data directory fails to upgrade, please follow the instructions printed by ./launcher rebuild or you may refer to the ins…

@tgxworld .. is this related ?  
I did a git pull, rebuild, at the end the output told me to rebuild again to complete migration.  
Now it won’t complete

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [April 4, 2018, 8:14am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/6 "2018-04-04T08:14:50Z")

</div>

```
LoadError: /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer_extension.so: undefined symbol: _ZTIN2v811ArrayBuffer9AllocatorE - /var/www/discourse/vendor/bundle/ruby/2.4.0/gems/mini_racer-0.1.11/lib/mini_racer_extension.so

```

Looks like an error in one of the javascript files.

Can you try disabling all the plugins and adding them back one by one?

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 8:17am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/7 "2018-04-04T08:17:02Z")

</div>

@zogstrip including dockmanager?  
I tried disabling everything except docker manager, cakeday, and spoiler (pretty basic stuff) and still the same error

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [April 4, 2018, 8:18am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/8 "2018-04-04T08:18:07Z")

</div>

Can you share the whole log? There might be something else going on here.

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 8:20am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/9 "2018-04-04T08:20:53Z")

</div>

> [@zogstrip](#):
>
> Can you share the whole log? There might be something else going on here.

[https://terminaladdict.com/discourse\_failed\_build.txt](https://terminaladdict.com/discourse_failed_build.txt)

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [April 4, 2018, 8:22am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/10 "2018-04-04T08:22:54Z")

</div>

Seems like you’re getting rate limited by rubygems. I would wait a few minutes and try again later.

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 8:25am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/11 "2018-04-04T08:25:04Z")

</div>

@zogstrip .. sorry, don’t understand 😕 .. It’s my host, can I tune something ?

---

<div class="post-metadata">

### Author: ![tgxworld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tgxworld/32/106117_2.png) [@tgxworld](https://meta.discourse.org/u/tgxworld)
#### Post date: [April 4, 2018, 8:25am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/12 "2018-04-04T08:25:47Z")

</div>

Can you also post your `app.yml` but do remove any sensitive fields before doing so.

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [April 4, 2018, 8:26am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/13 "2018-04-04T08:26:45Z")

</div>

There’s unfortunately nothing you can do except wait for the rate limit to be cleared.

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 8:28am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/14 "2018-04-04T08:28:40Z")

</div>

> [@tgxworld](#):
>
> Can you also post your app.yml but do remove any sensitive fields before doing so.

```
root@companion-cube:/var/discourse $ cat containers/app.yml
## this is the all-in-one, standalone Discourse Docker container template
##
## After making changes to this file, you MUST rebuild
## /var/discourse/launcher rebuild app
##
## BE *VERY* CAREFUL WHEN EDITING!
## YAML FILES ARE SUPER SUPER SENSITIVE TO MISTAKES IN WHITESPACE OR ALIGNMENT!
## visit http://www.yamllint.com/ to validate this file as needed

templates:
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  # - "templates/web.ratelimited.template.yml"
  # - "templates/web.socketed.template.yml"
## Uncomment these two lines if you wish to add Lets Encrypt (https)
# - "templates/web.ssl.template.yml"
# - "templates/web.letsencrypt.ssl.template.yml"

## which TCP/IP ports should this container expose?
## If you want Discourse to share a port with another webserver like Apache or nginx,
## see https://meta.discourse.org/t/17247 for details
expose:
    - "10080:80" # http
      #- "2222:22" # http
    # - "443:443" # https

params:
  db_default_text_search_config: "pg_catalog.english"

  ## Set db_shared_buffers to a max of 25% of the total memory.
  ## will be set automatically by bootstrap based on detected RAM, or you can override
  db_shared_buffers: "2048MB"

  ## can improve sorting performance, but adds memory usage per-connection
  #db_work_mem: "40MB"

  ## Which Git revision should this container use? (default: tests-passed)
  version: stable

env:
  LANG: en_US.UTF-8
  # DISCOURSE_DEFAULT_LOCALE: en

  ## How many concurrent web requests are supported? Depends on memory and CPU cores.
  ## will be set automatically by bootstrap based on detected CPUs, or you can override
  UNICORN_WORKERS: 4

  ## TODO: The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: www.mcrides.co.nz

  ## Uncomment if you want the container to be started with the same
  ## hostname (-h option) as specified above (default "$hostname-$config")
  #DOCKER_USE_HOSTNAME: true

  ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'paul@paulwillard.nz'

  ## TODO: The SMTP mail server used to validate new accounts and send notifications
  DISCOURSE_SMTP_ADDRESS: 'smtp.address.com'
  DISCOURSE_SMTP_AUTHENTICATION: 'plain'
  DISCOURSE_SMTP_PORT: 587
  DISCOURSE_SMTP_USER_NAME: 'secretUser@address.co.nz'
  DISCOURSE_SMTP_PASSWORD: 'myPasswordIsNotThis'
  DISCOURSE_SMTP_ENABLE_START_TLS: true # (optional, default true)

  ## If you added the Lets Encrypt template, uncomment below to get a free SSL certificate
  #LETSENCRYPT_ACCOUNT_EMAIL: me@example.com

  ## The CDN address for this Discourse instance (configured to pull)
  ## see https://meta.discourse.org/t/14857 for details
  #DISCOURSE_CDN_URL: //discourse-cdn.example.com

## The Docker container is stateless; all data is stored in /shared
volumes:
  - volume:
      host: /var/discourse/shared/standalone
      guest: /shared
  - volume:
      host: /var/discourse/shared/standalone/log/var-log
      guest: /var/log

## Plugins go here
## see https://meta.discourse.org/t/19157 for details
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/davidtaylorhq/discourse-whos-online.git
          - git clone https://github.com/discourse/discourse-spoiler-alert.git
          - git clone https://github.com/discourse/discourse-cakeday.git
          - git clone https://github.com/angusmcleod/discourse-events.git
          - git clone https://github.com/angusmcleod/discourse-locations.git
          - git clone https://github.com/discourse/discourse-tooltips.git
          - git clone https://github.com/discourse/discourse-push-notifications.git
          - git clone https://github.com/communiteq/discourse-sitemap.git

## Any custom commands to run after building
run:
  - exec: echo "Beginning of custom commands"
  ## If you want to set the 'From' email address for your first registration, uncomment and change:
  ## After getting the first signup email, re-comment the line. It only needs to run once.
  #- exec: rails r "SiteSetting.notification_email='info@unconfigured.discourse.org'"
  - exec: echo "End of custom commands"

```

---

<div class="post-metadata">

### Author: ![tgxworld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tgxworld/32/106117_2.png) [@tgxworld](https://meta.discourse.org/u/tgxworld)
#### Post date: [April 4, 2018, 8:30am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/15 "2018-04-04T08:30:46Z")

</div>

Ahh you’re on the stable branch..we might be missing a backport or smth.

---

<div class="post-metadata">

### Author: ![tgxworld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tgxworld/32/106117_2.png) [@tgxworld](https://meta.discourse.org/u/tgxworld)
#### Post date: [April 4, 2018, 8:49am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/16 "2018-04-04T08:49:45Z")

</div>

@TerminalAddict Try rebuilding again 🙂

I had to backport [Update libv8 from 5.9 to 6.3 · discourse/discourse@c2ff0f1 · GitHub](https://github.com/discourse/discourse/commit/c2ff0f1f3ca19f26affb9bb896b800e7036bbc82) to stable

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 9:03am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/17 "2018-04-04T09:03:06Z")

</div>

rebuilding now, looks good so far .. will report back in 5 mins

---

<div class="post-metadata">

### Author: ![TerminalAddict](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/terminaladdict/32/119676_2.png) [@TerminalAddict](https://meta.discourse.org/u/TerminalAddict)
#### Post date: [April 4, 2018, 9:09am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/18 "2018-04-04T09:09:44Z")

</div>

@tgxworld .. perfect !! thanks ❤

---

<div class="post-metadata">

### Author: ![Stranik](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/stranik/32/85638_2.png) [@Stranik](https://meta.discourse.org/u/Stranik)
#### Post date: [April 4, 2018, 11:30am UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/19 "2018-04-04T11:30:07Z")

</div>

`2018-04-04 11:11:29.123 UTC [59] postgres@postgres ERROR: database "discourse" already exists`

> **Summary**
>
> ```
> 2018-04-04 11:02:11.971 UTC [47] LOG: listening on IPv4 address "0.0.0.0", port 5432
> 2018-04-04 11:02:11.971 UTC [47] LOG: listening on IPv6 address "::", port 5432
> 2018-04-04 11:02:11.980 UTC [47] LOG: listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
> 2018-04-04 11:02:12.018 UTC [50] LOG: database system was shut down at 2018-04-04 11:01:03 UTC
> 2018-04-04 11:02:12.034 UTC [47] LOG: database system is ready to accept connections
> I, [2018-04-04T11:02:16.937951 #15] INFO -- :
> I, [2018-04-04T11:02:16.938359 #15] INFO -- : > su postgres -c 'createdb discourse' || true
> 2018-04-04 11:02:17.014 UTC [60] postgres@postgres ERROR: database "discourse" already exists
> 2018-04-04 11:02:17.014 UTC [60] postgres@postgres STATEMENT: CREATE DATABASE discourse;
> createdb: database creation failed: ERROR: database "discourse" already exists
> I, [2018-04-04T11:02:17.016859 #15] INFO -- :
> I, [2018-04-04T11:02:17.017184 #15] INFO -- : > su postgres -c 'psql discourse -c "create user discours e;"' || true
> 2018-04-04 11:02:17.092 UTC [71] postgres@discourse ERROR: role "discourse" already exists
> 2018-04-04 11:02:17.092 UTC [71] postgres@discourse STATEMENT: create user discourse;
> ERROR: role "discourse" already exists
> I, [2018-04-04T11:02:17.094738 #15] INFO -- :
> 
> ```

app.yml

> **Summary**
>
> ```
> ## this is the all-in-one, standalone Discourse Docker container template
> ##
> ## After making changes to this file, you MUST rebuild
> ## /var/discourse/launcher rebuild app
> ##
> ## BE *VERY* CAREFUL WHEN EDITING!
> ## YAML FILES ARE SUPER SUPER SENSITIVE TO MISTAKES IN WHITESPACE OR ALIGNMENT!
> ## visit http://www.yamllint.com/ to validate this file as needed
> 
> templates:
> - "templates/cron.template.yml"
> - "templates/postgres.template.yml"
> - "templates/redis.template.yml"
> - "templates/sshd.template.yml"
> - "templates/web.template.yml"
> # - "templates/web.ratelimited.template.yml"
> ## Uncomment these two lines if you wish to add Lets Encrypt (https)
> - "templates/web.ssl.template.yml"
> ##- "templates/web.letsencrypt.ssl.template.yml"
> ##- "templates/web.socketed.template.yml"
> 
> ## which TCP/IP ports should this container expose?
> ## If you want Discourse to share a port with another webserver like Apache or nginx,
> ## see https://meta.discourse.org/t/17247 for details
> expose:
> - "25654:80" # http
> - "443:443" # https
> 
> params:
> db_default_text_search_config: "pg_catalog.russian"
> 
> ## Set db_shared_buffers to a max of 25% of the total memory.
> ## will be set automatically by bootstrap based on detected RAM, or you can override
> db_shared_buffers: "256MB"
> 
> ## can improve sorting performance, but adds memory usage per-connection
> #db_work_mem: "40MB"
> 
> ## Which Git revision should this container use? (default: tests-passed)
> #version: tests-passed
> 
> env:
> LANG: en_US.UTF-8
> # DISCOURSE_DEFAULT_LOCALE: en
> 
> ## How many concurrent web requests are supported? Depends on memory and CPU cores.
> ## will be set automatically by bootstrap based on detected CPUs, or you can override
> UNICORN_WORKERS: 2
> 
> ## TODO: The domain name this Discourse instance will respond to
> DISCOURSE_HOSTNAME: toxu.ru
> 
> ## Uncomment if you want the container to be started with the same
> ## hostname (-h option) as specified above (default "$hostname-$config")
> #DOCKER_USE_HOSTNAME: true
> 
> ## TODO: List of comma delimited emails that will be made admin and developer
> ## on initial signup example 'user1@example.com,user2@example.com'
> DISCOURSE_DEVELOPER_EMAILS: ' ***@yandex.ru,*** @narod.ru'
> 
> ## TODO: The SMTP mail server used to validate new accounts and send notifications
> DISCOURSE_SMTP_ADDRESS: ***.ru
> DISCOURSE_SMTP_PORT: 587
> DISCOURSE_SMTP_USER_NAME: ***.ru
> DISCOURSE_SMTP_PASSWORD: ***
> ##DISCOURSE_SMTP_ENABLE_START_TLS: true # (optional, default true)
> 
> ## If you added the Lets Encrypt template, uncomment below to get a free SSL certificate
> ##LETSENCRYPT_ACCOUNT_EMAIL: ***
> 
> ## The CDN address for this Discourse instance (configured to pull)
> ## see https://meta.discourse.org/t/14857 for details
> #DISCOURSE_CDN_URL: //discourse-cdn.example.com
> 
> ## The Docker container is stateless; all data is stored in /shared
> volumes:
> - volume:
> host: /var/discourse/shared/standalone
> guest: /shared
> - volume:
> host: /var/discourse/shared/standalone/log/var-log
> guest: /var/log
> 
> ## Plugins go here
> ## see https://meta.discourse.org/t/19157 for details
> hooks:
> after_code:
> - exec:
> cd: $home/plugins
> cmd:
> - git clone https://github.com/discourse/docker_manager.git
> - git clone https://github.com/discourse/discourse-no-bump.git
> - git clone https://github.com/discourse/discourse-solved.git
> - git clone https://github.com/discourse/discourse-push-notifications.git
> - git clone https://github.com/communiteq/discourse-sitemap.git
> - git clone https://github.com/discourse/discourse-spoiler-alert.git
> - git clone https://github.com/discourse/discourse-cakeday.git
> 
> ## Any custom commands to run after building
> run:
> - exec: echo "Beginning of custom commands"
> ## If you want to set the 'From' email address for your first registration, uncomment and change:
> ## After getting the first signup email, re-comment the line. It only needs to run once.
> ## - exec: rails r "SiteSetting.notification_email='***@yandex.ru'"
> - exec: echo "End of custom commands"
> 
> ```

So do I remove the discourse database? I do not understand.

```
root@bigtor:/var/discourse# ./launcher enter app
root@bigtor-app:/var/www/discourse# cd /shared/postgres_backup
root@bigtor-app:/shared/postgres_backup# sv stop unicorn
ok: down: unicorn: 0s, normally up
root@bigtor-app:/shared/postgres_backup# sudo -iu postgres dropdb discourse
root@bigtor-app:/shared/postgres_backup# sudo -iu postgres createdb discourse
root@bigtor-app:/shared/postgres_backup# sudo -iu postgres psql discourse < backup.db
bash: backup.db: No such file or directory

```

---

<div class="post-metadata">

### Author: ![tgxworld](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tgxworld/32/106117_2.png) [@tgxworld](https://meta.discourse.org/u/tgxworld)
#### Post date: [April 4, 2018, 2:58pm UTC](https://meta.discourse.org/t/help-rebuild-app-failed/84538/20 "2018-04-04T14:58:54Z")

</div>

Can you provide us with the full log? Thank you

[Next page](https://meta.discourse.org/t/help-rebuild-app-failed/84538.md?page=2)
