Help with using CURL and API for Create Users


(Jared Needell) #1

I’m trying to use curl and the api to import a user and it doesn’t seem to be working. Can you see what I am doing wrong?


(Kane York) #2

You need to put quotes in the URL, the bash shell is interpreting the &s as a command separator.


(Jared Needell) #3

I just did that and I don’t get any response.

I’m also trying it with chrome’s advanced rest api and it says no response and a 500 internal server error


(Kārlis Gaņģis) #4

I had the same issue - user create API returning empty response and 500 internal server error.

Finally discovered the cause - we are using SSO and local users were disabled. I checked “Enable local username and password login based accounts. (Note: this must be enabled for invites to work)” under Settings/Login and the API started to work.


(Jared Needell) #5

@riking @sam

Can this get fixed to allow Create users even if local user/password is turned off?


(Jared Needell) #6

Just wanted to confirm, the create users endpoint does work when I enable Local Logins. When I disable that, it doesn’t work. I’d like the users to use their Google Apps SSO that I have configured but not have to register on their first login.

Thanks @Knagis on that find!


(Jared Needell) #7

Any updates on this?