Help: You are running an old version of the Discourse image?

This notice always show up on /admin/upgrade/.
Even if I already did this steps (2 times already):

To do so log in to your server using SSH and run:

    cd /var/discourse
    git pull
    ./launcher rebuild app

Other commands I also run hoping it will be gone:

wget -qO- https://get.docker.com/ | sh
./launcher cleanup

Also I just rebooted the server now.

Still showing:

2 Likes

I am also experiencing the exact scenario. I used the following command which should’ve updated my Docker image to the lastest (v18) and I’m still receiving the same error.

wget -qO- https://get.docker.com/ | sh

2 Likes

Unless you are on an ancient version of Docker this shouldn’t be needed.

Does ./launcher rebuild app errors out?

EDIT: Nevermind found the bug!

5 Likes

I just build this server and site last August 2 under Ubuntu 18.04.

No error.

Thanks for reporting. This should now be fixed per Correct minimum required version · discourse/docker_manager@f207959 · GitHub

Run ./launcher rebuild app one more time and it should work.

7 Likes

No, it works but it still gives the error on admin/upgrade/.

JS; I had Docker 15.0 I believe which is why I did the wget docker command

Thanks, solved now (all up to date).

2 Likes