High dockers CPU usage


(Mark Alldritt) #1

I suspect I’m experiencing the same issue as Docker using a lot of CPU. I’m sorry, but Discourse and docker are black boxes to me.

While docker is using almost all my server’s CPU my site is still up.

I began the process of trying to downgrade docker, as suggested in the link above, but I fell at the first hurdle. The docker rm -f app command failed with this error:

root@discourse-2gb-nyc3-01:~# docker rm -f app 
Error response from daemon: Could not kill running container 8bba540a7daa9d35c1091824856d4ff017fc5df8b97f0247b5e0f00581f780df, cannot remove - Cannot kill container 8bba540a7daa9d35c1091824856d4ff017fc5df8b97f0247b5e0f00581f780df: connection error: desc = "transport: dial unix /var/run/docker/containerd/docker-containerd.sock: connect: connection refused": unknown

Docker version:

root@discourse-2gb-nyc3-01:~# docker version
Client:
 Version:      17.11.0-ce
 API version:  1.34
 Go version:   go1.8.3
 Git commit:   1caf76c
 Built:        Mon Nov 20 18:36:37 2017
 OS/Arch:      linux/amd64

Server:
 Version:      17.11.0-ce
 API version:  1.34 (minimum version 1.12)
 Go version:   go1.8.3
 Git commit:   1caf76c
 Built:        Mon Nov 20 18:35:10 2017
 OS/Arch:      linux/amd64
 Experimental: false

Docker info:

root@discourse-2gb-nyc3-01:~# docker info
Containers: 1
 Running: 1
 Paused: 0
 Stopped: 0
Images: 3
Server Version: 17.11.0-ce
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 15
 Dirperm1 Supported: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: N/A (expected: 992280e8e265f491f7a624ab82f3e238be086e49)
runc version: 0351df1c5a66838d0c392b4ac4cf9450de844e2d
init version: 949e6fa
Security Options:
 apparmor
Kernel Version: 3.13.0-77-generic
Operating System: Ubuntu 14.04.4 LTS
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.955GiB
Name: discourse-2gb-nyc3-01
ID: QISU:YGAG:4WAU:NSM3:CIKB:DZEJ:PUJZ:EA3H:Q2GZ:7N4J:5KRR:RAB7
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false

And here’s the system’s CPU usage for the last 24 hours:


(Mittineague) #2

I don’t know if it applies to your issue or if you have already tried it. But I have found that often I need to prepend commands with “sudo”. Sometimes I’ll see “permission” in the read out that clues me in, but other times not.


(Sam Saffron) #3

Try changing to the stable docker stream, uninstalling docker, reinstalling, rebuilding discourse


(Mark Alldritt) #4

Okay. Is there a post that describes how do what you describe?