How can I change the favicon after installed


#1

Recently the logo for my organization has been changed, and therefore, the logo for the forum should also be changed. However, it seems like I couldn’t change it besides in the First Start Wizard

So, how could I change the favicon (the little icon at the tabs on browsers) in discourse?


(Felix Freiberger) #2

Feel free to visit the wizard again! It’s hiding at /wizard. Re-running it is totally fine.

Alternatively, edit favicon url in Settings :slight_smile:


#3

oh, thanks it works :smile:


(Amar Kumar) #4

Hi, just on this what size favicon works?

Because I have been trying to add a 16x16 PNG favicon on the site, but it does not seem to like it.

Thanks in advance.


(Joshua Rosenfeld) #5

What do you mean by?

Are you receiving some sort of error messsage from Discourse? Does the icon simply not appear in the browser?


(Amar Kumar) #6

Hi, sorry what I meant is that when I upload the favicon file as a png and apply it in the settings it does not appear… I have also tried 32x32 but still getting the same thing.


(Joshua Rosenfeld) #7

So what does appear? An older icon you previously uploaded, or the default Discourse icon?


(Amar Kumar) #8

The default discourse icon


(Joshua Rosenfeld) #9

I cannot reproduce this. It took a few refreshes, but after running the wizard and adding a new favicon image it updated. You can see a very stretched cat here:


(Amar Kumar) #10

Ah,that’s one thing I have not tried… I’ll run it through the wizard. Hopefully that sorts it out, ill update you on the situation.

Thanks.


(Jeff Atwood) #11

That’s odd because the first advice you got, the literal first reply to this topic, is to use the wizard. Maybe try following the advice?


(Amar Kumar) #12

I assumed you didn’t have to run the initial wizard again to change the favicon, so I tried changing the setting directly.

Surely it should work both ways right?


(Jeff Atwood) #13

I suggest following the advice given, rather than choosing your own random path.


(Amar Kumar) #14

Yes my bad, old habits die hard. :wink:


(Stephen Chung) #15

Favicons are cached in many browsers and stay old even when refreshing. It is frustrating sometimes to get a new favicon to show on a browser tat already has been to the site. The only surefire way I find is to clear the entire browsing cache.


(Graeme Stuart) #16

I have had this error for a long while now.

When I look at the settings I can see the url I have used

When I copy the url into a browser, it loads the image without any errors or problems.

Can anyone explain what I am doing wrong. I am still getting the default discourse favicon on my site.


(Michael Brown) #17

Works for me:

image

Perhaps the DNS doesn’t work from your container so Discourse doesn’t realize it’s OK.

What happens if you change the setting to:

/uploads/default/original/1X/f156fc35baee07ba19c72ebc00581d1977025e06.jpg


(Graeme Stuart) #18

Fantastic, that’s my solution. Thanks.


(Mittineague) #19

Does this have anything to do with the recent change where uploaded image hashes were shortened?


(Michael Brown) #20

I don’t think that would have any interaction, no.