How do I set up the WordPress Discourse plugin?


(ned) #1

I am currently trying to set this up in wordpress, I installed the wp-discourse plugin thu wordpress. How do I disable the original comment system?


Our Second Partner: Boing Boing
(Sam Saffron) #2

You need to save your actual posts with the “publish to discourse” option checked.


(ned) #3

Where I do that its taking me to this error page

Warning: file_get_contents(/posts) [function.file-get-contents]:
failed to open stream: No such file or directory in
/home/content/81/11594981/html/wp-content/plugins/wp-discourse-master/wp-discourse.php
on line 358

Warning: First parameter must either be an object or the name of an
existing class in
/home/content/81/11594981/html/wp-content/plugins/wp-discourse-master/wp-discourse.php
on line 363

Warning: Cannot modify header information - headers already sent by
(output started at
/home/content/81/11594981/html/wp-content/plugins/wp-discourse-master/wp-discourse.php:358)
in /home/content/81/11594981/html/wp-admin/post.php on line 222

Warning: Cannot modify header information - headers already sent by
(output started at
/home/content/81/11594981/html/wp-content/plugins/wp-discourse-master/wp-discourse.php:358)
in /home/content/81/11594981/html/wp-includes/pluggable.php on line
875


(ned) #4

What could be the cause of these warnings?


(To The Tick Llc) #5

Testing the Discourse WP Plugin and it throws up a ‘little’ issue for me…the image below is my blog normally

As soon as I activate the Discourse plugin this happens…

Any ideas?


(Ben T) #6

You may be hiding PHP errors that are preventing the page from displaying… or maybe CSS has gone wild and has hidden your content.

In the page source, is the missing stuff still there?


(To The Tick Llc) #7

No its not there The source becomes less than a 3rd of its original size.


(Ben T) #8

Are there any PHP errors to report then? Maybe you can enable them with these options.


(To The Tick Llc) #9

Thanks for your help, will have to get my developer to take a look at those options and set it up.


(Lowell Heddings) #10

My guess would be that your web host doesn’t have curl enabled, so the file_get_contents function can’t open the stream. That’s causing the problem.


(ned) #11

I have to look into this thanks.


(erica) #12

Was this issue ever solved? I checked to see if curl was enabled on my server (it is), yet this issue keeps popping up:

Warning: file_get_contents(/wordpress.json?best=5&min_trust_level=1&min_score=15&min_replies=1&bypass_trust_level_score=50): failed to open stream: No such file or directory in /homepages/2/d246508845/htdocs/maphappy/wp-content/plugins/wp-discourse-master/wp-discourse.php on line 162

I don’t know if this is because I need to enable some kind of JSON API; or do I need to further tweak something further in my settings such as the URL?


(Ben T) #13

Can you:
curl http://<your discourse install>/t/1/wordpress.json?best=5&min_trust_level=1&min_score=15&min_replies=1&bypass_trust_level_score=50

and see data relevant to the first topic? If there are any access errors they will need to be sorted out first.

You can also substitute /t/<topicid> with another topic if needed.


(Jeff Atwood) #14

I moved a post to a new topic: Every time I attach media in WordPress, a separate topic is created


(erica) #15

It was an issue in my settings for some reason — I ended up just copying what was displayed in the screenshot of the setup, though now I’m working on making sure they get published in the right category.