How does discourse start TLS when connecting MTU? EHLO or HELO?

email

#1

The MTU with TLS enabled is exim4 which I am using.

Auth method is plain user name and password with TLS enabled.

My app.yml setup is

DISCOURSE_SMTP_ADDRESS: mail.xx.com
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_USER_NAME: bm9yZXBseMuY29t
DISCOURSE_SMTP_PASSWORD: amFu
DISCOURSE_SMTP_ENABLE_START_TLS: true
DISCOURSE_SMTP_AUTHENTICATION: “login”

When test logging and sending email from localhost, remote address or inside docker container using openssl command, the mail could be sent successfully.

But when I login into admin panel and try to send test mail or invite mail to my friends, the mail logs shows

503 AUTH command used when not advertised

As we know,

exim4 defines

EHLO (not HELO) must be given by client before AUTH

When using HELO,

the mail server shows

503 AUTH command used when not advertised ,

So if discourse use HELO by default to connect mail server,

if this is could not be change,

the email could not get authorization and be sent successfully by exim4 wiht TLS.

Is this one of the reasons we could not configure email settings successfully?

Or if you can add EHLO option to connecting mail server?

@sam @codinghorror @eviltrout


Testing SMTP and watching logs?