How to force downloading images on imported data


(Jay Pfaffman) #1

I’ve imported a bunch of data with images. I changed download remote images max days old to a big number. Is there a way that I can force them to download? I don’t see an obvious process in Sidekiq.

Do I need to rebake? Just be patient?


(Tomek) #2

Does anyone have an answer to this question? :slight_smile:
I have the same issue.


(Régis Hanol) #3

Changing that setting and rebaking all the posts should work.


(Tomek) #4

I was trying to refresh HTML for an individual post but images were not pulled to a local storage.
Will rebaking all posts work in this case?


(Régis Hanol) #5

:thinking: I’ll have a look.

“Refresh HTML” is the user-friendly term for “rebaking” so if it doesn’t work then, a rebake won’t fix it.


(Tomek) #7

I’m trying to pull images for this post:

I changed the download_remote_images_max_days_old to 10k days but it does not work. After migration from IPB I had this setting to 30 days by default and images for older posts were not pulled. I’m trying to fix this now.


(Andrew Waugh) #8

Tomek,

Does the remote image actually exist?

I have a similar post here: [Saloon-lovers] color chips - Saloons - Jag-lovers Forums

Not surprising, it’s a decade old. Cute Puppy though.


(Tomek) #9

Yes they do. This is a CDN site for all the images of my previous IPB forum. I can access these images from my internal network and so is the server - wget http://forum.dpcdn.pl/xzyimage.png works fine.


(Tomek) #10

Does anyone know how to solve this problem?


External images crawling broken