How to include Sent As name in invitations and other system-related email?


(Christopher Baker) #1

Hi there, I’m running discourse v1.7.0.beta3 +11 and everything is working great, except I’m wondering if it is possible to set a “Sent As” name for invitation and other transactional emails. Private messages, topics, etc are all set with the name of the sender, which works well. The problem is that messages like invitations show up as being from “noreply” (or as the test example below “hello”), which means some users are ignoring them.

Anyway, here are a couple examples with the raw email headers:


and the headers


also example 2


and the headers

Thanks so much for the great project!


(Jay Pfaffman) #2

Usually the thing to do for questions like this is do a search in Settings. You can either guess at what the fields might be called, or just search for the text you want to be changed. So, search settings for “noreply” and you’ll find the “notification email” email setting.


(Christopher Baker) #3

Hi @pfaffman thanks for the response – I did get that far

But my problem isn’t setting the email, rather it’s setting the display name that is sent with the transactional emails. For topic-emails, etc, the user’s name is inserted. I’d like to, at the very least have it display the site.name when sending transactional emails.

Any tips on how to set that up?


(Jay Pfaffman) #4

You can’t always tell. It took me a while to that out. :slight_smile:

How about email subject?

[%{site_name}] %{optional_pm}%{optional_cat}%{topic_title}

Customizable subject format for standard emails. See Customize subject format for standard emails


(Christopher Baker) #5

:slight_smile: Yeah, I also modified the subject and it looks great (I’m using a custom short prefix, rather than site.name) — but it’s the naked email “noreply” (as shown in the images I originally included) that I’m worried about. I’ve had a user say they he ignored the invitation email because when scanning through his inbox, it tends to just skip things that say “noreply” or the like.

Anyway, somehow in the system, there’s some control over setting the actual sent email-headers from just

From: noreply@ats.community

to

From: ATS Community <noreply@ats.community>

or more generic

From: %{site_name} <%{notification_email }>

… or something like that (not sure of my placeholders) for invite and other system emails.


(Jay Pfaffman) #6

Well, I’m apparently no actual help :slight_smile: , but if you can’t find it in settings, you can find every-freakin’-thing in /admin/customize/text content. It’s a big haystack, though.


(Christopher Baker) #7

I appreciate you jumping in and trying @pfaffman I really do!


(Kane York) #8

Search for “hello” in the settings instead of “nore”.


(Christopher Baker) #9

Hi @riking – sorry the screen shots were taken at two different times, once when I had the notification email set as “hello@ats.community” and once later when I had the notification email set as “noreply@ats.community”. I’m still not finding any settings that allow me to change the actual notification email display name for these transactional emails (password reset, invitation, etc).


(Kane York) #10

Hmm, is it the title setting then?


(Christopher Baker) #11

I would love it if would set the outgoing email header to From: %{title} <%{notification_email }>, but alas it doesn’t currently. I do have the title variable set in my settings, but it doesn’t seem to affect the outgoing From: email header.


(Shoaib Amir) #12

hi guy, did you find solution, how to show sender email name instead of full email address.

I want to display it in inbox as email name instead of email address

for example received email from " Discourse" instead of "noreply@discourse.org"

I am not talking about email title/subject