# Discourseを別のサーバーへ移行する方法（同じDNS名を維持）

**URL:** https://meta.discourse.org/t/how-to-migrate-discourse-from-one-server-to-another-with-the-same-dns-name/175572
**Category:** Self-hosting
**Created:** [2021 年 1 月 9 日午前 5:03 UTC](https://meta.discourse.org/t/how-to-migrate-discourse-from-one-server-to-another-with-the-same-dns-name/175572 "2021-01-09T05:03:08Z")
**Posts on this page:** 1
**Showing post:** 11

<div class="post-metadata">

### Author: ![kenkendk](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kenkendk/32/117947_2.png) [@kenkendk](https://meta.discourse.org/u/kenkendk)
#### Post date: [2024 年 4 月 12 日午前 10:12 UTC](https://meta.discourse.org/t/how-to-migrate-discourse-from-one-server-to-another-with-the-same-dns-name/175572/11 "2024-04-12T10:12:20Z")

</div>

詳細な手順をありがとうございます。私も同様のことを、新しいホストへの移行で行いました。  
サイトは動作していたので、バックアップをやり直すのは避けたく、ここに記載されている手順に従いました。

ほぼうまくいきましたが、新しいホストでの再構築が失敗しました。  
原因は、2つのホスト間でUID/GIDのマッピングが完全に同じではなかったため、Postgresの起動時にデータフォルダの所有権が正しくなく、エラーが発生したことでした。

これは他のインスタンスでも起こりうることで、[幸いなことに修正方法があります](https://meta.discourse.org/t/postgresql-13-update-from-postgresql-10-fails/192865/10)。

この投稿のシナリオには、もう一つ追加の注意点があります。それは、コンテナがビルドされていないため、この段階では `./launcher enter app` が機能しないことです。再構築にはかなりの時間がかかるため、`docker ps` を使用してビルド中のコンテナ名を取得し、コンテナに入ることができました。

```plaintext
docker exec -it <container_name> bash
chown -R postgres:postgres /shared/postgres_*

```

その後、再構築は失敗します（または CTRL+C で停止できません）。停止した後、再度実行するだけで、権限が修正されます。

```plaintext
./launcher rebuild app

```

そして、再び動作するようになりました 😅 。

---

_[View the full topic](https://meta.discourse.org/t/how-to-migrate-discourse-from-one-server-to-another-with-the-same-dns-name/175572)._
