How to pg_upgrade on docker postgres?


(Roof) #1

I want to upgrade my postgresql 9.5 into 9.6.
i’ve tried this but doesn’t work. PostgreSQL: Documentation: 9.6: Installation Procedure
when i run pg_upgrade at docker exec, cannot run as a root. fyi i installed on debian
anyone can help? thanks.


(Jeff Atwood) #2

Not recommended until we have upgraded Postgres to version 10 in our image. It’s not tested nor supported, any higher version than 9.5 at this time.


(Roof) #3

Thanks for your info. so, what your suggest if i want to upgrade my docker postgresql?


(Jay Pfaffman) #4

That you wait until support for postgres greater than 9.5 has been added.


(Joshua Rosenfeld) #5

For reference:


(Darix) #6

JFYI: 9.6 works just fine. the problems started with PG 10


(Roof) #9

oh i see.
but i still got confused how to upgraded to 9.6 version.
i’m stuck with that