# How to resolve Pups exec errors during Discourse bootstrap

**URL:** https://meta.discourse.org/t/how-to-resolve-pups-exec-errors-during-discourse-bootstrap/362619
**Category:** Support
**Created:** [April 18, 2025, 12:38pm UTC](https://meta.discourse.org/t/how-to-resolve-pups-exec-errors-during-discourse-bootstrap/362619 "2025-04-18T12:38:46Z")
**Posts on this page:** 1
**Showing post:** 21

<div class="post-metadata">

### Author: ![RGJ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rgj/32/523185_2.png) [@RGJ](https://meta.discourse.org/u/RGJ)
#### Post date: [April 22, 2025, 10:37pm UTC](https://meta.discourse.org/t/how-to-resolve-pups-exec-errors-during-discourse-bootstrap/362619/21 "2025-04-22T22:37:23Z")

</div>

> [@Thomas\_Rother](#):
>
> therefore `name: redis and alias: data`

I still don’t understand why you rename the one and not the other.  
But it’s likely not your problem anyway, since

> [@Restore fails with "hotlinked\_media\_status" already exists](https://meta.discourse.org/t/restore-fails-with-hotlinked-media-status-already-exists/323795/7):
>
> One very valuable insight that I just had is that `hotlinked_media_status` is simply the first thing happening in the restore file. If you remove it manually in the existing database the restore will fail on the next statement (`CREATE TABLE public.admin_notices`).

Most of the time this indicates a permissions problem.

Make sure the user Discourse uses to connect to your database has full rights on your database, including the ability to enumerate tables. Preferably make it the owner.

---

_[View the full topic](https://meta.discourse.org/t/how-to-resolve-pups-exec-errors-during-discourse-bootstrap/362619)._
