How to use Unicode user name like Japanese?


(Hidetaka Ko) #1

I can’t use Japanese username like below. It puts 1111 instead of ひでたか

Of course I tried to google solutions in google like below.

I installed plugin like below and rebuild app.

hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/zh99998/discourse-username-localization.git
          - bash discourse-username-localization/install.sh

And, I changed this option from false to true like this.

display_name_on_posts:
    client: true
    default: true

But, it didn’t work.


(Rafael dos Santos Silva) #2

We don’t have support for unicode on usernames currently, only on names.


(Hidetaka Ko) #3

But, he is using unicode on username.


(Jeff Atwood) #4

No that is full name. Username is not Unicode but full name is.


(Hidetaka Ko) #5

How can I set the full name?
prioritize username in ux is enabled, disabling it has no effect on this.


(Jeff Atwood) #6

Edit full name in your user preferences. You can also set it at signup time, it is prompted for.


(Hidetaka Ko) #7

I can’t edit full name on my environment.


(Jeff Atwood) #8

Looks like full name is suppressed on your instance.


(Hidetaka Ko) #9

It works. Thanks. I appreciate you.