# HTTP 422 when moving topics with invalid title length

**URL:** https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629
**Category:** Feature
**Created:** [May 29, 2018, 5:23am UTC](https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629 "2018-05-29T05:23:19Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![fhe](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/fhe/32/113345_2.png) [@fhe](https://meta.discourse.org/u/fhe)
#### Post date: [May 29, 2018, 5:23am UTC](https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629/1 "2018-05-29T05:23:19Z")

</div>

I’m moving a lot of topics from one category to another and some of them simply won’t move. I’m getting an error modal with

> 422 No Reason Phrase

in those cases.

I’ve investigated the error log and it seems that the title is too short for those topics. Could this be given as reason instead of the more generic text?

Also, enforcing min topic length when moving topics seems not necessary.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 29, 2018, 5:32am UTC](https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629/2 "2018-05-29T05:32:56Z")

</div>

How did the topics get created with invalid titles in the first place?

---

<div class="post-metadata">

### Author: ![fhe](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/fhe/32/113345_2.png) [@fhe](https://meta.discourse.org/u/fhe)
#### Post date: [May 29, 2018, 5:51am UTC](https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629/3 "2018-05-29T05:51:03Z")

</div>

I’ve imported them from IPB, where I didn’t have such a strict rule about topic length.

Even without importing, I can change min topic length from 15 to, e.g., 20 in Discourse and create invalid titles. Those topics then show the same issue if they fail to conform to the new rule.

I think when renaming topics, the rule should be enforced. After I’ve discovered what was causing the HTTP error, I now quickly change the setting, move the topic and revert the settings change.

If you’re curious about why I not simply refine the topic title to something longer: those topics are quite old, and I don’t want to make them reappear under latest. Just move them to where they now belong.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 29, 2018, 6:41am UTC](https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629/4 "2018-05-29T06:41:19Z")

</div>

So change the minimum title length, then move them. Problem solved.

---

<div class="post-metadata">

### Author: ![fhe](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/fhe/32/113345_2.png) [@fhe](https://meta.discourse.org/u/fhe)
#### Post date: [May 29, 2018, 8:15am UTC](https://meta.discourse.org/t/http-422-when-moving-topics-with-invalid-title-length/88629/5 "2018-05-29T08:15:14Z")

</div>

Sure, this is what I’m doing:

> [@fhe](#):
>
> I now quickly change the setting, move the topic and revert the settings change.

This was added as a side-note to my initial report. The more relevant part is:

> [@fhe](#):
>
> I’ve investigated the error log and it seems that the title is too short for those topics. Could this be given as reason instead of the more generic text?

Instead of

> 422 No Reason Phrase

something like

> 422 Title too short (min length is X characters)

What do you think about a more verbose message to the user?
